Contribution Plugin Screencast

I have watched the Contribution plugins screencast. I cannot find any consent or Thankyou file to modify; nor can I find the add,php file mentioned. My file/directory structure does not seem to be the same as that in the screencast.
Question 2: Items seem to be getting uploaded when I tried out the contribute option, but I keep getting an error message (enable error logging), which I have tried to do by following the directions. But I still get the same error message; meanwhile the item does get uploaded. I am not sure if the error thing is some kind of permissions problem with my server--I have asked my tech support for help.

I found the Consent and the other files. I have not solved the error problem.

Are you running Contribution version 1.0-1.1?

Yes, I am using Contribution 1.0-1.1.
So, while the item is getting uploaded using the contribute feature, instead of a thank you message, we get an error message.
Second, while I have tried to enable error logging, nothing is getting written to the error log file.

This could be an issue with your server's setting and how the mail function is being accessed after a user submits their contribution. I would ask your IT folks about this as well.

I will stride into the valley of death to do battle with our IT folks; this will not be pretty.