Contribution Plugin - Install error - Unknown column 'long_text' in 'field list'

I am trying to install the Contribution plugin. Previously it said I needed to upgrade my version of Omeka to install it, so I have no upgraded to 2.2.2. When I click the install button for this plug in it goes to a page that says
Omeka has encountered an error

When i turn on detailed error messages it says
Mysqli prepare error: Unknown column 'long_text' in 'field list'

Is there a way I can fix this?

What is the full error message? It should include things like line numbers that will help narrow down the problem.

This is the rest of it:
#0 /home/content/51/9193051/html/ Zend_Db_Statement_Mysqli->_prepare('INSERT INTO `om...')
#1 /home/content/51/9193051/html/ Zend_Db_Statement->__construct(Object(Zend_Db_Adapter_Mysqli), 'INSERT INTO `om...')
#2 /home/content/51/9193051/html/ Zend_Db_Adapter_Mysqli->prepare('INSERT INTO `om...')
#3 [internal function]: Zend_Db_Adapter_Abstract->query('INSERT INTO `om...', Array)
#4 /home/content/51/9193051/html/ call_user_func_array(Array, Array)
#5 /home/content/51/9193051/html/ Omeka_Db->__call('query', Array)
#6 /home/content/51/9193051/html/ Omeka_Db->query('INSERT INTO `om...', Array)
#7 /home/content/51/9193051/html/ Omeka_Db->insert('ContributionTyp...', Array)
#8 /home/content/51/9193051/html/ Omeka_Record_AbstractRecord->save()
#9 /home/content/51/9193051/html/ ContributionPlugin->_createDefaultContributionTypes()
#10 [internal function]: ContributionPlugin->hookInstall(Array)
#11 /home/content/51/9193051/html/ call_user_func(Array, Array)
#12 /home/content/51/9193051/html/ Omeka_Plugin_Broker->callHook('install', Array, Object(Plugin))
#13 /home/content/51/9193051/html/ Omeka_Plugin_Installer->install(Object(Plugin))
#14 /home/content/51/9193051/html/ PluginsController->installAction()
#15 /home/content/51/9193051/html/ Zend_Controller_Action->dispatch('installAction')
#16 /home/content/51/9193051/html/ Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
#17 /home/content/51/9193051/html/ Zend_Controller_Front->dispatch()
#18 /home/content/51/9193051/html/ Zend_Application_Bootstrap_Bootstrap->run()
#19 /home/content/51/9193051/html/ Zend_Application->run()
#20 /home/content/51/9193051/html/ Omeka_Application->run()
#21 {main}

Had you installed the Contribution plugin before?

The error you're getting is caused by the database table being set up incorrectly. The only way I can think of for that to happen with the way Contribution works is if you had an old, preexisting table sitting in your database.

The easiest way forward is probably to just delete any omeka_contribution tables you have in your database and try installing again.

A while back I tried to install it, on a previous version of Omeka, but it didn't work then so I deactivated it.

I will try deleting the tables. thank you!

That worked, thank you again!