Contribution forms won't load when Geolocation plug-in installed!?

Wonder if anyone can help - I've been happily plodding along, using the Contribution plug-in with no problems until yesterday when I went on our 'front-end' site to test the Contribution form after editing my Terms of Use.

The form wouldn't load following selection of Item Type, and although I couldn't initially work out what had caused this error, I went through and uninstalled recently installed plug-ins one by one. It appears the error is linked to the Geolocation plug-in, as when I uninstall this, the form goes back to working as it should.

I love the Geolocation plug-in - it's a wonderful extra layer for our users to explore the items in our archive - but as our site is primarily a 'collecting' site, the Contribution form working properly is pretty crucial!

I have a couple of questions, I guess:

1. Has anyone else ever encountered this before? It seems a little strange to my uneducated brain...

2. Does anyone have any suggestions for a fix that would allow me to have the best of both worlds - both the Geolocation and the Contribution plug-ins with no negative effects on either?

What versions of both plugins and Omeka are you using? It's possible there's some incompatibility that would be solved by upgrading one or all of those pieces of the puzzle.

Thanks John.

We're currently on Version 3.0 of Contribution and 2.0.1 of Geolocation - does that help?


It does, thanks! We're checking on it.

Keep in mind that 3.0 Contribution sounds like you've grabbed it from GitHub. Since we've been actively working on it, it's also possible that the current code fixes the issue.

There's also a newer version of Geolocation available, which might also have fixed it.

I haven't been able to reproduce this with 2.0.1 of Geolocation or the current version. Hopefully that means that the current Contribution has it fixed. If you still have the same problem with updated plugins, though, please let us know.

Thanks so much for your help :)

I thought I should let you know - we're now all updated and we're still having the same problem. I'm leaving out the Geolocation plugin for now for that reason, but if you come upon a solution or you manage a fix for the future, I'd be keen to know!

Has there been any resolution to this problem? The same thing happens to my site, and it also seems to be related to geolocation plugin.

Not sure if this is the same root cause as the earlier discussion, but I noticed that when I had no internet access, I could reproduce the problem. That's a lead, at least, and I'll check into it.

Thanks! Is it ok to keep this thread active, or should I start a new one?

So far, the problems seem similar enough to keep it as the same thread because of the geolocation issue.