Changing navigation

We are running Omeka 2.0.4 and are having problems when we try to change the navigation in the theme configuration. We go to Appearance and then Configure Theme and select the Navigation tab. From there, we check the box for Scripto. I click the arrow on Scripto to look at the details and the URL is correct and I can View Public Page successfully. When I click on Save Changes, I see the following error displayed:

"The navigation settings were not saved because of missing or invalid values. All changed values have been restored."

"Navigation links that have undeleteable sublinks cannot be deleted."

I've tried this on Thanks Roy, Berlin and also on the Seasons theme and all do the same thing. Any suggestions?

Can you make any changes whatsoever?

And, also, what other plugins besides Scripto do you have installed? (You can easily get a list of them and their versions from the "System Information" link in the admin footer).

No, it appears that I can't make any changes to the navigation settings.

Plugins running are:

Coins 2.0.1
CollectionTree 2.0.1
Commenting 2.0
CsvImport 2.0
DocsViewer 2.0
Dropbox 0.7.1
ExhibitBuilder 2.0.4
Geolocation 2.0.1
LcSuggest 2.0.1
Neatline 2.0.4
NeatlineFeatures 2.0.1
NeatlineTime 2.0.2
Scripto 2.0
SimplePages 2.0.2
SimpleVocab 2.0.1

Okay, and do you have any custom-added links in the navigation? In particular, ones where the URL matches up with a URL added by a plugin (including a Simple Page) can be problematic.

I don't see anything. Here's what I see on the navigation screen. Hope this is what you are asking for.

Check the links to display them in the main navigation. Click and drag the links into the preferred display order.

Browse Items
Browse Collections
Historical Timelines
Transcribe It


Add a Link to the Navigation

Specifically, the ones I'm interested in are any links on there that you added yourself. You can tell them apart because they'll have an "x" over on the right, since you can delete them.

For example, I see both "Scripto" and "Transcribe It" links in your pasted navigation. Did you add one or more of those manually, and what are the URLs if so?

They're both for the transcriptions associated with the Scripto plugin. Scripto DOES NOT have an X on the right, but Transcribe It DOES.

Scripto goes to /peoplescontest/scripto

Transcribe it goes to /peoplescontest/transcribe-it

Could the hyphen be causing problems?

I just checked the links to view the public page and they both work.

Transcribe It!
are both SImple Pages

You said the "Transcribe It" link has an X on the right. That would mean it's a manually-added link, not one coming from Simple Pages (plugin-added links don't have the X).

If you go and look at the Simple Page admin for the transcribe-it page, is the "publish" box checked?

If so, I think that could be the problem: temporarily unchecking the publish option for that page should let you edit the nav again (including deleting your manual transcribe-it link, which Simple Pages will automatically add back when you turn "publish " back on).

Yes that worked thanks!

Glad to hear it.

This information should help us fix the underlying problem in an Omeka update, too.

Yeah, we appreciate it much John. Thanks from me as well.

Version 2.1.2 is out, and Omeka should automatically resolve these sorts of URL conflicts now.