changing dublin core titles/subtitles

I am wondering if it is possible to NOT display the words "Dublin Core" for each item on our database. Also, if it is possible to change the titles of the fields themselves (e.g., re-title the "identifier" field as "call number"). I realize that Dublin Core is a standard, so this might not be possible. Otherwise, is there a way to not display ANY Dublin Core fields, just the Item Type Meta-Data fields?

Thanks for you help!


Someone recently asked about this on the dev list:

You'll need to open the 'item-metadata.php', in application/view/scripts/items, that governs the display of item metadata.

custom_show_item_metadata(), which uses show_item_metadata(), uses this template file for formatting.

If you want to remove the 'Dublin Core' heading, you could just copy the 'item-metadata.php' file to your own theme (in theme-name/items/), and remove the line '<h2><?php echo html_escape(__($setName)); ?></h2>'. this will remove the Dublin Core heading, and all subsequent headings for element sets.

If you only want to remove it for Dublin Core, you could just do a check on $setName, something like this:

<?php if ($setName != 'Dublin Core'): ?>
<h2><?php echo html_escape(__($setName)); ?></h2>
<?php endif; ?>

While you're at it, you can of course modify any of the other HTML for element sets, element names, and values as you'd like in this template file.

Thanks Sheila!

I have been struggling with getting rid of the "Dublin Core" text in the item display for the last two days. I've tried copying 'item-metadata.php' to the theme 'items' directory (in several themes) and deleting the line as suggested, editing 'item-metadata.php' itself (commenting the line out, deleting it AND using the 'check' suggestion), switching back and forth among themes, everything I can think of and nothing works.

I can edit other files and have the changes show up, so I don't think it's a permission problem. However, I am new to Omeka. I must have missed something really obvious.

Thanks for anything!

My best guess is that it really is a permissions problem, that the server doesn't have permission to read the file. In that case, Omeka would go back to reading the original item-metadata.php. The fact that you can edit other files and have changes show up might still make sense if the server always had permission to those files. It might be that when copying the file over, the permissions were somehow changed.

So, I'd say check to make sure that the file is readable by the web server.


Hi Patrick,
Thanks for the advice.

I deleted 'item-metadata.php' from the theme folder and re-uploaded the original 'item-metadata.php', to application/view/scripts/items to go back to the original state as installed. I then set all of the permissions for 'item-metadata.php' to read/write/execute for owner, group and public (numeric value 777) and took out the offending <h2> line. I can see that both the permissions and the file have changed on the server, but this damned label still shows!

I checked up the directory hierarchy and none of the preceding directories' permissions "recurse into subdirectories."

I am using Filezilla to move files, manage permissions, etc., logged in to the admin account I used to install Omeka. The site is fully hosted at

I'm really stumped. Any suggestions?

I'd take a look at the custom_show_item_metadata function in application/views/scripts/functions.php.

Sheila's advice is right for every element set heading except for Dublin Core. The Dublin Core heading gets printed right in that function, so you'd need to take it out of there if you want it to be gone.

You could also change your theme to just use the "normal" show_item_metadata function, which does obey the item-metadata.php changes for all element sets. (You'd lose the ability to specify the Dublin Core fields you want to show if you do this, though.)


I commented out $html = '<h2>' . __('Dublin Core') . '</h2>'; in the custom_show_item_metadata function in application/views/scripts/functions.php and it worked! The "Dublin Core" label is gone and nothing else seems affected.

Thanks again.

I am also trying to remove the words "Dublin Core" and "Item Type Metadata." I have 2.0.1 installed and can't find these files or the element-set div. Anyone know where these are?


I have figured some of this out- In /home/richfield1854/ there is a file named record-metadata.php.

I commented out 2><?php echo html_escape(__($setName)); ?></h2> and the words "Dublin Core" are no longer appearing at the top of either the items or collections show page.

You went to the right place.

There's no longer a custom_show_item_metadata function, and item-metadata.php moved to record-metadata.php.

I'd recommend that you copy common/record-metadata.php into your theme and make the change there, rather than editing the core file directly. Direct editing will work, but your changes could easily be overwritten by an upgrade.

I use 2.0.1
and I copy and

remove the line '<h2><?php echo html_escape(__($setName)); ?></h2>'

root@yaguarete:/var/www/themes/seasons/items# more record-metadata.php

<?php foreach ($elementsForDisplay as $setName => $setElements): ?>
<div class="element-set">
<?php foreach ($setElements as $elementName => $elementInfo): ?>
<div id="<?php echo text_to_id(html_escape("$setName $elementName")); ?>" class="element">
<?php foreach ($elementInfo['texts'] as $text): ?>
<div class="element-text"><?php echo $text; ?></div>
<?php endforeach; ?>
</div><!-- end element -->
<?php endforeach; ?>
</div><!-- end element-set -->
<?php endforeach;

but I see the word dublin core again



It looks like that item's not public, so people can't see it unless they're logged in to the site.

Anyway, from what you've pasted, I think you copied the file to the wrong place. Your working directory in the command you posted is "seasons/items," but the record-metadata.php file goes into "seasons/common"

now I see the problem..
the file
that is in the directory

In these file I must remove the line
<?php echo html_escape(__($setName)); ?></h2>


I'm wondering if anyone has an update on this. It seems very bizarre to me that Dublin Core is always shown as a header item on all pages, it's just a lousy design idea to be honest. I can't believe there is no easy way to remove this, let alone that it's there at all. Reading through this thread seems to be a lot of outdated info as people are referring to files that don't exist in the current 2.1.4 version of Omeka (and it's related default themes like Seasons 2.1.6). I see in the config.ini file for Seasons the last line talks about excluded field, but I can't make sense of what it's supposed to be doing. If I were to follow logic, it says display_dublin_core_fields is excluded, but that seems unlikely. The comment indicates exclusion "if they wish" but I see no place in the UI to configure these. Is this really supposed to be done at the config file level instead of in the UI? And back to the original issue, how the heck do you get rid of that Dublin core header on all the pages??

This will be configurable on the admin side in the next release of Omeka.

In the meantime, newer threads on the same question better reflect the current state of affairs.