Can't Upload multiple files in Omeka 1.5.3

Hi everyone, I ran into problem of uploading multiple files in a new 1.5.3 Omeka installation.
Before I had 1.5.2, and when uploading a file I could click browse select the file and then I had an option and I could click another browse right under to upload another file. That way I could select multiple files and then upload them at once.

With new 1.5.3 installation I only have one browse option to select the file for upload and then I will have to go back after upload to edit the item and then I could upload another file. This gets very annoying when you trying to upload 30+ newspaper articles.

Can anyone please help or point to the direction how this can be solved.

Here is the link for screenshot.

I can't reproduce this problem.

This looks like a JavaScript issue. Can you make sure the problem persists when reloading, clearing cache, or switching browsers?

Hi John

The problem does still exist if I reload, clear cache and I tried 3 different browsers Firefox, Chrome, and Internet Explorer.

similar problem occurred posted on on this thread a year ago by another person.

Looking at the old thread, all my php.ini settings are set correctly including increase number of upload for post_max_size and upload_max_filesize

That other thread is talking more about the form being fine, but the uploads themselves not working.

Your problem really does seem to be something related to the javascript or the markup for that form: you're getting the "no javascript" fallback instead of the button that lets you add additional upload boxes.

The other javascript on that edit page is working correctly? This would be things like the tabs on the left side, the HTML editor and adding new inputs on the Dublin Core tab.

Everything works perfectly on the edit page, all the tabs, HTML editor and Dublin Core.

The only thing is I can upload multiple files when I get to the files tab when updating or creating an item. Its like missing something in the code.

Wait, is there something different between updating or creating an item with that tab? (Or, did you mean, "can't," not "can upload"?)

I'm not sure what's going on here. I don't see the same issue on a 1.5.3 install, whether adding or updating items. Is it possible that you've made edits to this page or the JavaScript, or had some issue upgrading?

If you see JavaScript or web console errors reported in any of the browsers you've tried, that information would be helpful in figuring out what's up.

Sorry I was just typing to fast and not proofreading "The only thing is I CAN'T upload multiple files when I get to the files tab when updating or creating an item. Its like missing something in the code"

There is absolutely no errors, and installation went very smooth.

I guess I will just have to try new installation on a different server.

If you would like to access the admin menu of my installation, give me an email address to where i can send you the access information, if you would like to see the closer look of this.

We've narrowed this down to a problem in the PdfSearch plugin.

Deactivating the plugin is an easy temporary solution, and the problem should be easy to fix in the plugin.

Wow! Thanks you guys rock!
Will you guys release a new version of PdfSearch soon?
Thank you so much for your help.

Also if you guys could make something in the future, where we can just hit browse select all the files that need to be uploaded for one item and just hit upload. That will be the best!

The new version of PdfSearch (1.0.1) is up.

Just installed the new version of PdfSearch.
Works Great!
Many Thanks guys!