Can't install Neatline plugin

Hello Omeka community!

I'm having trouble making Neatline work.

I have tried to install it several times following the standard procedure for plugins, every time it says the plugin was successfully installed but no Neatline tab is shown on the admin bar. I don't know which URL that link should point to, I tried both http://myipaddress/admin/neatline and http://myipaddress/admin/neatline-exhibits but with no luck (the software throws two different exceptions to be honest, I can write them down if it may be useful).

I have the error printing enabled, but after the installation nothing came up neither on the browser nor on application/logs/errors.log. If I look to my system informations Neatline regularly sits along the other plugins. You can find them below.

I'm sorry but I have no clue how to better troubleshoot it at the moment.

Any help is appreciated.

Thank you in advance,

    Browser:            Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.22 (KHTML, like Gecko) Ubuntu Chromium/25.0.1364.160 Chrome/25.0.1364.160 Safari/537.22
    Role:               super

    Omeka:              1.5.3
    PHP:                5.3.10-1ubuntu3.5 (apache2handler)
    OS:                 Linux 3.2.0-31-generic x86_64
    MySQL Server:       5.5.24
    MySQL Client:       5.5.24
    Apache:             Apache/2.2.22 (Ubuntu)

PHP Extensions
    Regular:            apache2handler, bcmath, bz2, calendar, Core, ctype, date, dba, dom, ereg, exif, fileinfo, filter, ftp, gettext, hash, iconv, json, libxml, mbstring, mhash, mysql, mysqli, openssl, pcre, PDO, pdo_mysql, Phar, posix, Reflection, session, shmop, SimpleXML, soap, sockets, SPL, standard, sysvmsg, sysvsem, sysvshm, tokenizer, wddx, xml, xmlreader, xmlwriter, zip, zlib

    CsvImport:          1.3.4
    Dropbox:            0.6
    DublinCoreExtended: 1.1
    ExhibitBuilder:     1.2.1
    Geolocation:        1.2
    Neatline-1.1.2:     1.1.2
    OaipmhHarvester:    1.0
    OpenLayerZoom:      0.1

    Minimalist Omeka Theme:1.2
    Rhythm:             1.3
    Seasons:            1.3
    Thanks, Roy:        1.5 (current)

Judging from the name given in your System Info output, it looks like you've got the Neatline plugin folder named incorrectly.

I'd try uninstalling the plugin through the Omeka interface, then renaming the plugin folder to just "Neatline" and then installing again (the order there is important: uninstall before renaming the folder).

The "-1.1.2" on the end looks like an oversight on the developers' part when they uploaded the latest zip file.

Hi John, I've followed your advice and it works!

Thanks again for helping and sorry for the delay.