BookReader and omeka 2.3.1

I can't activate the BookReader plugin for Omeka 2.3.1. (this is not a valid extension)
Is it possible ?
If it is, what did I miss ?

You added the plugin to your plugins folder but you're not able to click install on the Plugins page? Or is it not showing up on the Plugins folder at all?

Can you give us the exact error you're getting?

I added it in the plugins folder, went to the plugins admin page, and there it appeared, but without any buttons, and a message in french "Ce n'est pas une extension valide" which means it's not a valid extension.
I tried this version of the plugin :
The plugin.ini says
omeka_target_version = "2.3"
I don't know whether it can run with 2.3.1 or not.
Thanks for your help.

Well, I didn't understand why, but now it works...
There were in my plugins folder several different folders for the same BookReader plugin, with different versions.
I removed the old folders, and then it works.

So, yes, BookReader can run with omeka 2.3.1 !


On Github, plugins are renamed according to the branch (master) or the commit, and it should be renamed to the true plugin name in your installation.


Daniel Berthereau
Infodoc & Knowledge management