Blank screen after 2.0 upgrade

Hello all -

So, I just tried upgrading my system from omeka 1.5.3 to 2.0. and I'm having issues! I am developing locally on a linux 12.10 machine.

After I initially installed and navigated to the login page, things seemed to be working fine. I got into my upgraded admin page and checked out my files, which looked undamaged. Then I went in to start activating my plugins and that's when the trouble started. I noticed things slowing down as I started to activate plugins, but ignored it, since I assumed it was just the system upgrading. Then I tried to upgrade the Docs Viewer - I clicked on the "activate" button and then tried to navigate to the Docs Viewer configuration. Before I could do that my screen went blank. I haven't been able to get into my admin or any omeka pages since then.

I tried restarting apache and my computer several times with no luck. I also tried turning editing my config.ini file to both display error messages and track errors in a log. I made these both true:

debug.exceptions = true
log.errors = true

So far that's not telling me anything - the error.log isn't displaying anything and when I navigate to the admin login page nothing comes up but a blank white screen.

Any suggestions?

Thanks in advance!

Did you replace your old DocsViewer plugin with the new, 2.0-compatible version (also version 2.0)?

If it's just that you accidentally activated with the old plugin still in there, just deleting the old plugin folder and dropping in the new one should get you back up and running.

If you had already replaced the plugin directory, then it's a little more complicated.

The settings for enabling error display are slightly different in version 2.0, see the codex for details.

I've had the same problem, check here:

Documentation says (step 5) to move "Any themes or plugins you had installed" but this causes problems. My problem was my old theme.

My advice: Use a stock, "bundled" theme of v2.0. Also, start by using only the 3 "bundled" plugins and see how it goes.

Messing with database/server settings will only waste your time.

Great thanks both of you for your help! It must have been my plugins. I removed all except the 3 come that pre-installed and things worked just fine. I re-installed all of my plug-ins that were 2.0 compatible and my system seems to be working fine.

I am missing some of my old plug-ins theme still works but I do miss having so many other options. Will most of the other plugins be updated for 2.0?

We're in the process of updating more of the 1.x plugins to get them in shape for 2.0.

If you have specific examples of plugins you're missing, we might be able to say something more concrete about their status.

That's great to hear. I'm mostly missing the CSV import plugin - makes batch uploading so much easier.