Archive Folders Not Being Populated with Uploaded Images

When I upload an image, the "fullsize," "square_thumbnails," and "thumbnails" folders are not being populated. Though if I check through FTP, I see that the uploaded image did make it into the archives/file folder.

I do not receive any error messages, though I thought this might have something to do with ImageMagick. As far as I can tell though, ImageMagick works fine, at least from the command line. Or maybe this is a file permission error? All of my archive folders are chmod 755.

I've finally worked through a solution. It may be helpful for others, so I'll identify what I did to fix it:

(1) First my default installation of PHP did not have the exec function enabled. Once I enabled "exec" my Omeka finally began registering ImageMagick errors. So make sure you have exec enabled.

(2) I had the standard /usr/local/bin path for ImageMagick specified in Omeka. On my server at least, this was a symbolic link to another ImageMagick directory. I changed the Omeka settings to the actual directory.

(3) I had read that you no longer needed to include the "convert" at the end of the directory path in the Omeka settings. This did not work for me. Once I changed the path to include convert (i.e. .../bin/convert), my images were finally uploading without errors, and I was getting the thumbnails that I needed.

Interesting solution. Are you using the 1.0 alpha version of Omeka, or 0.10? If you're using 1.0, adding 'convert' to the path manually shouldn't work, because Omeka automatically appends it to the path that you see on the settings panel.

For example, if you had '/usr/local/bin/convert' listed on the admin settings panel, Omeka would think you meant '/usr/local/bin/convert/convert' and would fail.

This needed to be changed because of a security flaw that exists in 0.10.

Yes, I was using .10. And as I discovered with my recent upgrade to 1.1, the "convert" at the end of the path did indeed fail. I removed it, and imagemagick started working again in 1.1.