API import not working

I have the API import plugin installed on the local host, and activated on the remote host, with an API key. I attempt to import and all I get is the following message:

Status: starting Click here to update status.

I have tried and tried to check for other things that might need toggling, and have read previous threads on this forum that deal with this topic, but I am still no further along the line than I was 6 hours ago. I would really be grateful for some help here!

Just to clarify, the remote site api URL is http://gracewebster.omeka.net/api

To get some more debugging info, follow the guide here to activate error logging to application/logs/errors.log . Also, in application/config/config.ini make sure the logging priority is set to DEBUG

log.priority = Zend_Log::DEBUG

Then, try the import again, and if the errors.log file has new errors, please post a copy of them. The logs can be a bit gibberishy, but there should be a line that starts with the date and time of when you tried the import, like this:

2015-10-02T12:00:44-04:00 INFO (6): Beginning Import

Thanks for the advice. I did as you suggested, but the errors.log file is, as you say, gibberishy.

The site in question is http://gracewebster.omeka.net/ and I am entering http://gracewebster.omeka.net/api on the import interface. The API key is unclear; should I enter the localhost api or the remote host? I get the same message whichever I enter.

Everything posted is public access, so in theory it should be possible to import without an API key at all. I've tried that too, with the same result.

(BTW, I have enabled API by checking the box on remote host API settings page.)

ANYWAY, I just tried to import using http://gracewebster.omeka.net/api and the remote API key, but this time I got a *different* result: "Omeka has encountered an error".

In the log, under "All Messages", I find this:

03/10/2015 09:52:59.405 com.apple.InputMethodKit.UserDictionary[482]: CoreData: iCloud: Error: failed to receive initial sync notification call back in 90 seconds
03/10/2015 09:53:16.618 eprocsd[248]: failed to get args for proc 20004: Invalid argument
03/10/2015 09:53:16.618 eprocsd[248]: failed to get system proc list for pid 20004


Regarding the API key, it's the API key for the remote (gracewebster.omeka.net) site, and all good that the API is enabled on that site.

Quite correct, too, that if the items are public, those should import fine, regardless of the key. (The importer, though, will also try to import user and other data that does require an admin's key).

I was able to import item data to my laptop, so I'm now inclined to think that there's some twist in the local server settings at work. I haven't seen those particular errors before, but it seems likely that they are part of the problem -- if the background process doesn't get the data (args) it needs, not surprised by failure.

One possibility is to change the configuration for how Omeka tries to do processes like that. On the _local_ Omeka installation, go to application/config/config.ini and look for the "Background Scripts" section. Around line 166 there should be something like

jobs.dispatcher.longRunning = "Omeka_Job_Dispatcher_Adapter_BackgroundProcess"

Try changing that to

jobs.dispatcher.longRunning = "Omeka_Job_Dispatcher_Adapter_Synchronous"

It's a bit of a stab in the dark, but that _might_ get around the failed to get args for proc errors. The downside is that the server might timeout before completing the job, but if that happens and items get imported, it's still progress and we'll address that next bridge and the troll living under it.

OK, thanks. The response to that was:

04/10/2015 08:51:43.000 kernel[0]: process 27873 set trusted
04/10/2015 08:51:43.000 kernel[0]: Change trust on
04/10/2015 08:51:43.000 kernel[0]: process name uxipm_ui (pid 27873)
04/10/2015 08:51:43.000 kernel[0]: Change trust on
04/10/2015 08:51:43.000 kernel[0]: process name ��W����� ������ (pid 27873)
04/10/2015 08:51:43.000 kernel[0]: revoking trust for process 27873

Any update to that? I have a similar problem :(

Hi Patco. No, I'm still stuck. I've stopped working on the online database for now. Unless I can keep a backup I've got no guarantee it may not just disappear at any time.

hmm. what operating system and version are you using?

I'm using a MacBook running on OS X Yosemite 10.10.5. I can't recall all the steps I took to get Omeka working on a Mac (it was quite complicated!), but there's something called MAMP that seems to provide an environment for it. (Is that what it's doing? I'm not sure.)

Anyway, it all looks good and ready to roll, except for the fact that I can't import the database from omeka.net...

yes, MAMP is what provides your local server environment. I'm not especially familiar with MAMP environments, but some initial digging makes it look like something about 'trust' settings being revoked. Apple or MAMP forums might have more guidance.

Is the eventual destination for the data to your laptop, or is that a staging step before moving from omeka.net to another public server? If so, it might be worth seeing if you can do the staging there.

good information bout import

In my case I just want to have the data on my laptop (Macbook Air). If not, I'm worried the online data might disappear and there's no backup.

Understood, and wise! Will post again if I find anything about MAMP and trust settings, but we're pretty much at the same level of knowledge on that right now.