Any successfully installs using MAMP or XAMPP on OS X?

I've just not been able to get Omeka 2.3 installed properly on OS X 10.0.3 using either the current MAMP or XAMPP with ImageMagick installed in /opt/local/bin using Mac Ports.

If you've managed this with some variant of the above set of tools, could you please post a brief overview of what modications/configuration steps you had to undertake to make it work? Specifcally, to avoid file permission errors, Zend errors and ImageMagick (convert) not being found.

I have no idea if this will help you at all because I used Windows 7, and sometimes different operating systems are foreign lands, but I had many of the same problems. ImageMagick wasn't being recognized, so I followed the instructions on with modifications.

I found all my required info: XAMPP (version 5.6.8 / PHP 5.6.8) Apache 2.4.12 (Win32), Bitness 32, Visual C compiler version VC11, 2012, Thread safe

Then I downloaded NOT the first version of ImageMagick but the one that matched my bitness. I then had to go find vcomp110.dll and drop it into the folder because IM only gave me vcomp100.dll by default.

Then Omeka threw a storage exception that I fixed by restoring all the IM dll files to what they were when I originally downloaded IM. That is, kobashi recommends switching out all the IM dlls for the ones in the Imagick folder. Instead, I only took the Wand and Magick CORE dlls from Imagick and dropped them in IM.

I got a couple of errors after that, including a record exception, but found all the answers I needed on these forums. I also had to open up the permissions.

Again, I don't know if this will help, but it did result in a working version on Windows.

Hmm.. maybe I will look into MAMP on Windows. Thank you for writing this up. I'm more familiar with OS X but if it works on Windows, I should give it a go.

This thread might help

So far, using the current version of XAMPP, I've encountered the following problems:

First, /tmp on OS X 10.10.4 is not writeable to Omeka. So using a suggestion I found elsewhere in the forum, I created a new entry in the config.ini file called storage.tempDir and pointed this to a different directory. That solved that problem.

Next, an error message saying Omeka's files directory is not writeable. It is, in fact, 775 writeable, including enclosed items. To work around this, as a temporary workaround, I had to make it 777. I can live with this since this is just a be local test version of Omeka.

Finally, imagemagick's convert binary is still not being recognized although it is in /opt/local/bin via a macport install. I don't know how to fix this one.

The thread above led to two solutions. One was my own solution, three years ago, to switch to XAMPP to avoid the problems with MAMP. I might need to revert back to that version of XAMPP to see if it still works with Omeka today. The second was a suggested workaround for MAMP. Since I already have a Bitnami customized version of WordPress running well in XAMPP I'd prefer to make Omeka work in the same environment. But I might have no choice.