Another .jpg Uploading error in 1.5

Just got our installation up and running and am trying different filetypes. First jpg got this message:

#0 /var/www/html/omeka/application/libraries/Omeka/File/Derivative/Image.php(113): Omeka_File_Derivative_Image::createImage('/tmp/5ba2331d3a...', '1200', 'fullsize')
#1 /var/www/html/omeka/application/libraries/Omeka/File/Derivative/Image.php(222): Omeka_File_Derivative_Image::createDerivativeImages('/tmp/5ba2331d3a...')
#2 /var/www/html/omeka/application/models/File.php(248): Omeka_File_Derivative_Image::createAll('/tmp/5ba2331d3a...', 'image/jpeg')
#3 /var/www/html/omeka/application/models/File/ProcessUploadJob.php(24): File->createDerivatives()
#4 /var/www/html/omeka/application/libraries/Omeka/Job/Dispatcher/Adapter/Synchronous.php(25): File_ProcessUploadJob->perform()
#5 /var/www/html/omeka/application/libraries/Omeka/Job/Dispatcher/Default.php(95): Omeka_Job_Dispatcher_Adapter_Synchronous->send('{"className":"F...', Array)
#6 /var/www/html/omeka/application/models/File.php(70): Omeka_Job_Dispatcher_Default->send('File_ProcessUpl...', Array)
#7 [internal function]: File->afterInsert()
#8 /var/www/html/omeka/application/libraries/Omeka/Record.php(282): call_user_func_array(Array, Array)
#9 /var/www/html/omeka/application/libraries/Omeka/Record.php(561): Omeka_Record->runCallbacks('afterInsert')
#10 /var/www/html/omeka/application/libraries/Omeka/Record.php(581): Omeka_Record->save()
#11 /var/www/html/omeka/application/models/Item.php(303): Omeka_Record->forceSave()
#12 /var/www/html/omeka/application/models/ItemBuilder.php(213): Item->saveFiles()
#13 /var/www/html/omeka/application/libraries/globals.php(505): ItemBuilder->addFiles('Upload', 'file', Array)
#14 /var/www/html/omeka/application/models/Item.php(286): insert_files_for_item(Object(Item), 'Upload', 'file', Array)
#15 /var/www/html/omeka/application/models/Item.php(153): Item->_uploadFiles()
#16 [internal function]: Item->beforeSaveForm(Object(ArrayObject))
#17 /var/www/html/omeka/application/libraries/Omeka/Record.php(282): call_user_func_array(Array, Array)
#18 /var/www/html/omeka/application/libraries/Omeka/Record.php(803): Omeka_Record->runCallbacks('beforeSaveForm', Object(ArrayObject))
#19 /var/www/html/omeka/application/libraries/Omeka/Controller/Action.php(482): Omeka_Record->saveForm(Array)
#20 /var/www/html/omeka/application/controllers/ItemsController.php(99): Omeka_Controller_Action->editAction()
#21 /var/www/html/omeka/application/libraries/Zend/Controller/Action.php(516): ItemsController->editAction()
#22 /var/www/html/omeka/application/libraries/Zend/Controller/Dispatcher/Standard.php(295): Zend_Controller_Action->dispatch('editAction')
#23 /var/www/html/omeka/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
#24 /var/www/html/omeka/application/libraries/Zend/Application/Bootstrap/Bootstrap.php(97): Zend_Controller_Front->dispatch()
#25 /var/www/html/omeka/application/libraries/Zend/Application.php(366): Zend_Application_Bootstrap_Bootstrap->run()
#26 /var/www/html/omeka/application/libraries/Omeka/Core.php(165): Zend_Application->run()
#27 /var/www/html/omeka/admin/index.php(44): Omeka_Core->run()
#28 {main}

ImageMagick is installed in the appropriate place and the test returns "works"
The tmp directory is world writable and even has a temp copy of the image I was trying to upload in it. Along with various others including ImageMagick temp directories.
In hope!

Converted image to png and reuploaded, it was successfully converted and added to the database.

Have you tried any other JPEGs?

If JPEGs in general don't work, but PNGs do, then you've got a particularly strange problem happening.

JPEG's one of the most basic formats ImageMagick should support, but it's possible that it doesn't on your system (though that would be particularly odd since Omeka makes ImageMagick create JPEG images for the thumbnails).

Hi again,
The user who got this error said she reuploaded successfully later.
However another user has had a similar report while converting an image (also jpg, I believe). The sequence of lines is very similar but not identical (2 lines shorter).
Any tips on how to investigate this further?
The user sent me the error message as a graphic so I can't upload it here.

Could you be running low on space in your temporary directory?

Some servers have a limit on how much space /tmp can take up, and if there's a lot of junk in there, that would explain intermittent problems with ImageMagick saving the thumbnails.

Unfortunately not.

I'm not convinced the user did manage it successfully, I think they used a png version of the same file. No problems with them. GIFs also upload OK.

I have tried this today and got the same error again, so I think it is not specific to any one user or situation, just to the jpg image type.

The only remaining thing that makes sense to me that could be the problem is a problem with your ImageMagick installation that makes it unable to read (but able to write) JPEG files.

You can run the following command to see if your copy of ImageMagick reports that it can read JPEG files:

convert -list format | grep JPEG

Posting the output of that command would help show whether there's something obviously wrong with your ImageMagick install.

Thanks again for the continued support. this was the result.

/tmp$ convert -list format | grep JPEG
see part 5 which describes the image encoding (RLE, JPEG, JPEG-LS),
and supplement 61 which adds JPEG-2000 encoding.
JNG* PNG --- JPEG Network Graphics

I think this may be your issue. That was the only output you got? Fairly typical output for an installation would be something like:

see part 5 which describes the image encoding (RLE, JPEG, JPEG-LS),
           and supplement 61 which adds JPEG-2000 encoding.
      JNG* PNG       rw-   JPEG Network Graphics
     JPEG* JPEG      rw-   Joint Photographic Experts Group JFIF format (62)
      JPG* JPEG      rw-   Joint Photographic Experts Group JFIF format
    PJPEG* JPEG      rw-   Progessive Joint Photographic Experts Group JFIF

Those three extra lines you don't have in your output are the read/write support for "normal" JPEG files.

Did you install ImageMagick yourself, was it pre-installed, or did you have a host or IT handle it? It looks like a re-install of ImageMagick is probably in order; it's very odd for it not to have JPEG support.

Its our server, managed by central university IS (Centos 6.2) with installation of ImageMagick done immediately after the OS installation recently by the IS people. I've asked the Information Systems Support to reconfigure or reinstall it as I only have access to the Omeka folders.
May get back to you, this might take some time!

Thanks for your advice, the reinstall this morning did the trick.