All pages redirecting to "success" /install/

We have been running Omeka successfully on BlueHost for about a year. Last week, inexplicably, all of our Omeka installations started redirecting to the install page, no matter which URL is entered. I have tried deleting everything and copying from our sandbox server. I have also tried a new omeka installation - everything is stuck on this redirect loop.


I'm the only person in the department with administrative access to the site - could BlueHost have changed something on their end that would cause this issue?

Since you've had several sites affected all at once, some change on the server side is a likely culprit.

We redirect to the installer when there's an error loading the "options" table. In turn, the installer checks for the presence of the "options" table when it's deciding whether Omeka's already installed.

So, you seem to be in a situation where the "options" table is there, but there's some error when Omeka tries to actually read from it. Possibly there's been some change to the permissions for the database user you've configured Omeka to use in db.ini?

Thanks for the help! It turns out all of the MySQL databases had become corrupt. When I created a new database and redirected db.ini to it the site worked. Any idea how that could have happened? Is it possible our site has a security issue?

Luckily everything is backed up on a separate server, so I should be able to recover it relatively easily.

Thank you, again!