Admin interface throws an error

Upgraded from 1.32 to 1.4 Went to Admin interface and hit the "update database" button. Following that, public interface is fine. Admin interface bombs with "Oops! Sorry, this page doesn't exist. check your URL... in browser, URL shows as: http://[domain name of site]/admin/users/login.

DB shows omeka_version 1.4

Ran upgrade according to instructions on site.

Server: Ubuntu 2.6.24-16-server
Omeka: 1.4
php: 5.2.6-1+lenny9


If I hand code the /admin URL explicitly as:

http://xxxxxxx/admin/index.php [return]

instead of just

http://xxxxxx/admin [return]

then it seems to be OK. Still digging into why that would be the case.

Now i see that it works "OK" but it isn't right. When I enter


it goes to the admin user login screen (as it should) but the browser displays the URL as:


So something's still no right. Leaving out the index.php breaks admin login

Did you upgrade using SVN, or using a zipped release?

This looks like an .htaccess problem. Make sure you have updated the .htaccess file, since it changed between 1.3.2 and 1.4. There should now only be one, in the root of the site, and there should no longer be one in the admin directory.

If you're using Subversion, the updated copy will be called .htaccess.changeme, and you'll need to copy that over to .htaccess

Used the zipped download...and you're right. It was an .htaccess (URL rewrite) problem. I blew out all .htaccess files anywhere in the upgraded site and put one from the zipped download file in the omeka root. Problem solved. I'm guessing I failed to overwrite the older file with the new one when I did the upgrade.