Adding WMS to Neatline Exhibit


I've followed the directions outlined in the tutorial here:

However, when I view my exhibit the background displays as pink boxes with a broken image symbol. Is there any way to see whether this is an issue with the data I input into GeoServer or whether it's just not connecting correctly? I've tried several things and I'm just not sure how to troubleshoot this.

Thanks for your help!

Most likely the layer and basename are repeated. Say I have a map that had a filename of "my_map.tif", when it gets to Geoserver, it gets referenced with something like

If you've copied the URI, you would have

in the server URL, but if you take off the "Neatline" component, this should work.

To really answer your question though, the way we debug this is generally within the developer tools of the browser we're using (generally Chrome If you enable the network tab, you can see the response headers from the server that generate the pink tiles.


Thanks, Wayne.

I've tried a few combinations but it doesn't seem to work. Do I need to include the http:// ? In your example you include it but it doesn't display in my Geoserver URL.

Another question. "wms" doesn't show up in my Geoserver URL. I know in the tutorial it says that it should. Would that create problems?

As a follow up to my last post, I deleted the last word that displayed in my URL ("web") and added "wms". When I enter this WMS address the pink broken images do not appear--it's just a blank screen. When I try other combinations I get the pink broken image tiles again.

Do you think this indicates that the first WMS address is correct, and that there is perhaps a different issue that is causing my image not to display?

Any ideas you have would be very appreciated.

Is the WMS service public? If it's public, mind posting a link?

You do need the http protocol in the URL, even though many browsers now mask that.

Pink tiles can be the result of a lot of different problems (what can go wrong on the Internet, right?), but if you've got a URL to try, we can see better what's going on.


Here's a link to the exhibit, which is public:

Here's the WMS address:

Let me know if other information would be useful! I really appreciate your help.

Hi Wayne,

Any ideas about this? I'm going to be looking at it again this afternoon so I may have some fresh ideas soon.


I've just read over this thread, which seems to be relevant:

Do you think this is an issue with me inputting the wrong WMS address or is it a problem with the actual georectified file I am using? I wouldn't be surprised if it were the latter as we have had several problems with the file itself in the past.

Hey Brianna!

I actually can't get either of those sites to load - are they accessible to users outside the Indiana network? As for why the map isn't showing up, there could be a couple of reasons. Sometimes, depending on how the file was originally created, it's necessary to tune a couple of parameters in the Geoserver layer.

If you send me the file, I'll boot it up locally and see if I can get it working.


Hi David,

Thanks so much! I just sent you an email with a link to our georeferenced tiff.


My question is about wms
I use World Map Map Warper
I have these historic image georeferencing

and also can export wms base url
to neatline
I don't see the image.

Can help me?

Hi Gus,

So it looks like this resource doesn't have the png8 as an image type which is part of the request. I just wrote a bug report on this:



To to follow up, there is a branch with a fix for this at We'll continue testing this and hopefully roll this in to the next release. In case you can't wait that long (it's a long weekend here in the US), you can grab that branch.


Thanks very much . I change the line.

But I don't see the wms when add the address

These address is here:
when I export I have the wms 3433

Also I lost the spatial layers.

My map with WMS layers is

Also I add to Neatline

wms layers: argentina santa cruz
and never see the wms layers

Maybe you can see in my page

the problem

thanks for all

Try these values:

WMS Address:
Layers: 3433


it is the same


There may be another issue going on with this particular layer; I've gotten intermittent issues popping up, but it was working earlier when I tried it :)

But let's jump over to the ticket for more conversation on this...


I read through the forum here and at the github address provided by Wayne. However, I am still having issues with using georectified maps from WorldMap warper in Neatline. I have figured out that the georectified map I'm using works in Neatline version 2.2.0. However, I have the latest version of Neatline, 2.3.0, and it does not work in my Neatline exhibit. How can I make a change in the latest version? If not, I will uninstall and reinstall the older version.

Thank you!

Hi Lindsaytday,

Could you contribute to that Github issue thread? We want to make sure that we have layers to test against...You may also try the work around that mkane2 came up with (