adding spanish -- special characters on import

Having a problem. I can't seem to find clear directions. Do I use html entities or something else when I need to add an accented character.


You can use HTML for characters (for item metadata be sure you're checking the HTML box). Or, you may create the accented text in another program and copy it into the text boxes (and do not check HTML). Omeka uses UTF-8 so it will publish the marked up text without any trouble.

I am experienceing a similar problem. I have a csv file created in Excel. When imported to Omeka, the element data cuts off at the special character. ex... José Dolores López becomes Jos, cutting off at the accented é.

My client would like to have the csv correct at the time of import. It is much easier to se and correct accents in the csv/Excel rather than in Omeka admin.

Is there a software that creates csv files that is compatible with Omeka CSV Import plugin?

Is there a way of allowing special characters to be read by CSV Import?

LibreOffice's "Calc" is a replacement/equivalent for Excel, and it lets you choose what character set to use when saving a sheet as CSV. If you save the CSV with "UTF-8" as the character set, Omeka should be able to read the special characters just fine. It's usually possible to just use LibreOffice to open an existing .xls/.xlsx file and save it as CSV, if you'd prefer to use Excel for the actual data entry.

Alternatively, I believe Google Sheets can also output UTF-8 CSVs.

Thank you for the very quick response.

With your help, it looks like Notepad++ has a UTF 8 encoder that will convert the csv file to UTF 8 .txt with working results.

Load the .csv in Notepad++, go to Encoding and select Convert to UTF 8. Then save as a normal text file (.txt).

It uploaded to Omeka and is showing Spanish accents. Thank you again for pointing me in the right direction.

Yes, as long as the CSV contains all the characters you want in some encoding (this isn't always the case, but often is for simpler diacritics and accents), just converting the file after the fact is a valid way to go.

I've added a little note to the Preparing for CSV Import section of the plugin's docs to flag the issue a little more visibly.