Adding new input erases information in existing inputs

I have a field, titled "bibliography," that is part of an item type metadata. If I add new inputs for that field, and none of the fields have the "use html" box checked, everything works fine. But if that box is checked on any field, adding a new input erases whatever has been entered into the previous fields.

So, say I have inputs 1 and 2 (with html boxes checked), and they've already been saved to the database, an input 3 to which I've added some information too and checked the html box, but not saved to the database. Add an input 4 will erase what is in 3, but not in 1 or 2.

Might this be a bug?

Hmm, sounding like it is a possibility.
Which version are you working in?

What browser are you using? Seems likely that it is something in the javascript. thanks!

I'm on Omeka 2.0.2 and the latest version of Chrome. Here is all the information. Thanks.

Google Chrome 25.0.1364.172 (Official Build 187217)
WebKit 537.22 (@145275)
JavaScript V8
Flash 11.6.602.180
User Agent Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_5) AppleWebKit/537.22 (KHTML, like Gecko) Chrome/25.0.1364.172 Safari/537.22


Omeka 2.0.2

AddItemLink 0.1
CatalogSearch 0.1
Coins 2.0
CsvImport 2.0
EditLink 1.0
LcSuggest 2.0
SimplePages 2.0
SimpleVocab 2.0

ah. yep. seeing it in Chrome, but not Firefox

The ever-awesome @zerocrates has fixed the bug, so it will be in the next bugfix release.

You guys are great! and fast!

Do you prefer bug reports at GitHub?

Either place is happy with us for bug reports. We just want to keep other questions and discussion in the forums.

I've upgraded to Omeka 2.0.3, but I'm still noticing a bug when adding extra inputs. Before 2.0.3. if there was a input field with HTML enabled, adding a new input removed all the data in the existing field entirely. After 2.0.3, if there is an input field with HTML enabled, adding a new input keeps the text in the existing field, but strips out the HTML tags.

I'm using Chrome.

I can't reproduce this new report with Chrome. Unsaved content, including HTML, is preserved when adding new inputs.

Any other wrinkle to your steps to reproduce?

Here are the steps I just took to reproduce the issue.

1. Click the link "add new item."

2. In the Dublin Core field title, add the name "John Doe."

3. Click the use HTMl button.

4. Italicize the name.

5. Click add input.

The text "John Doe" remains, but it is not italicized.

Here is the output of the Omeka system information page.

Browser Mozilla/5.0 (Macintosh; Intel Mac OS X 10_7_5) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.65 Safari/537.31
Role super
Omeka 2.0.3
PHP 5.2.17 (cgi)
OS Linux 2.6.18-408.el5.lve0.8.61.1 x86_64
MySQL Server 5.0.96
MySQL Client 5.0.96
PHP Extensions
Regular bcmath, calendar, cgi, ctype, curl, date, dom, eAccelerator, filter, ftp, gd, gettext, hash, iconv, imap, ionCube Loader, json, libxml, mbstring, mcrypt, mysql, mysqli, openssl, pcre, PDO, pdo_mysql, pdo_sqlite, posix, pspell, Reflection, session, SimpleXML, snmp, soap, sockets, SPL, SQLite, standard, suhosin, timezonedb, tokenizer, xml, xmlreader, xmlrpc, xmlwriter, xsl, Zend Optimizer, zip, zlib
Zend the ionCube PHP Loader, Zend Optimizer
AddItemLink 0.1
CatalogSearch 0.1
Coins 2.0.1
CsvImport 2.0
EditLink 1.0
Geolocation 2.0 (inactive)
LcSuggest 2.0
SearchByMetadata 1.1
SimplePages 2.0.1
SimpleVocab 2.0
American Converts 2.0.1 (current)
Berlin 2.0
Seasons 2.1.1
Thanks, Roy 2.0.2

Yeah, I still can't reproduce this: the name stays italic after adding the new input.

Have you tried reloading more forcefully or clearing cache? Maybe you're picking up pieces of the old Javascript.

That must have been the problem, John. I cleared the cache, and it worked as expected.

Thanks for all the help.