Adding Links in Exhibit Builder Editor Not Working

I've noticed that when I add links using the hyperlink button in the Exhibit Builder construction page, it is automatically adding "/exhibit/" into the link. So, I can't get it to link directly to an item.

For example, I try to put:


But instead I get


I've even tried editing the text with the HTML button, but it still does the same thing. I've had this problem with all 3 Omeka sites I've built.

Any help would be most appreciated!

Hi Dave,

This is related, I think, to an issue we fixed in the latest release of ExhibitBuilder, version 0.5.2.. Are you using this version? If not, can you upgrade to it and see if you still have the problem?

Thanks Jeremy. Looks like I'm using 0.5.1. Will I have any issues if I simply download the new plugin ZIP and dump the files into the existing directory on my server? Should I run a backup first?

Upgrading the data should be fine, though it always wise to back up things. If you've made modifications to any exhibit themes, or made new themes/layouts, you should back those up as well and bring those into the new version you upload.

If you're interested in specific fixes we committed to the code, you can see the changelog for ExhibitBuilder 0.5.2 on our Addons Trac.

Great! I just changed the code for that piece rather than doing the upgrade, and it is working perfectly now. Thanks for the quick project is due on Tuesday...