404 for any but main page

It seems that others have similar problems, but I've tried everything in every other thread, so would like to check with anyone else might think.

I'm fairly convinced that this is a mod_rewrite or .htaccess issue, but I'm not sure where I'm going wrong.

I've got the htaccess files correctly installed (and have tried adding RewriteBase to them in various configurations).

I've got mod_rewrite enabled, and uncommented in httpd.conf (and I've got AllowOverrides All in httpd.conf, too).

This is an install on a Mac Server, running Leopard Server.

The install is at http://mycroft.mhc.cuny.edu/omeka . As you'll see, that main page loads fine, but nothing else--no Items page, and most of all no admin page. Just 404 errors for all of them.

The root of the install (since this is a Mac) is at /Library/Webserver/Documents/omeka . If that helps.

Glad to answer any other questions--I'm obviously missing something obvious. Any thoughts?

Hi Joe,

We don't officially support Mac Server, but a few of us run Omeka locally on our MacBook Pros, so I think this shouldn't be a problem to get going. Have you seen http://www.clagnut.com/blog/350/?

All urls that Omeka uses (youromekasite.com/items, or /collections) are created dynamically, and redirected via the .htaccess. If your server isn't reading the.htaccess file properly, then those URLs won't work (which appears to be the problem).


Well, this seemed like a good lead, but it didn't work for me. I had already made the change in /private/etc/httpd/httpd.conf and when I looked (as that blog post recommended) for other httpd.conf files in /private/etc/httpd/users there was no such directory!

But the lead was still a good one, because it led me to think (and google) more carefully about how to enable htaccess specifically in Leopard server (and why would Leopard server not be setup to recognize and work with htaccess files to begin with? I don't know).

So I did find the solution. You can mark this one closed.

Anyone trying to install Omeka on Leopard server, it can be done, and the secret is to open the Server Admin GUI on your server, and then go to Web> Sites> yoursite.com > Options . From there you have to select "Allow All Overrides," save, stop the web service, start it again, and all will be well.

Thanks for the help, Dave! You pointed me in the right direction.