2.2.2 upgrade and plugin issues

I just upgraded from version 2.1.2 to 2.2.2 following the upgrade Omeka instructions. Now I'm trying to activate my plugins once again however no matter which one I choose to try and activate, or what I do I always get "There was an error on the form. Please try again.". Any idea why this keeps happening and what I can do to fix this?

Those generally happen when the form has expired for security reasons. Clearing your browser's cache, or trying a different browser, might do the trick.

I tried clearing the cache and attempted to use a different browser but I'm still getting the same "There was an error on the form" message.

update: tried to upgrade to 2.3 and I have the exact same issue.

Have you altered the admin interface at all? (So, when you're upgrading, are you keeping any old files within the admin folder?)

Turns out since we were using a custom theme, we were missing $csrf in the plugin files, which it appears are necessary with the upgrade! Thanks all!