1st time user - initial experience: FAIL

ove the last 10 years, i've installed plenty of joomla, wordpress, PHP systems - mostly on 1and1.com servers.
but the frustration from the last 3 hours or so has made me wonder if OMEKA is worth it.

install went fine, even though I had to add "install.php" to the end.
ok, so that points to mod_rewrite, or does it?
i'm tired of reading posts about this.
install didn't complain (like for some others), so now its the "allowoverride"?

and ImageMagick wasn't producing thumbnails or even showing the big image. Discovered though trial and error that a 650k file would work and a 850k file (and larger, like an iphone pic) would fail on the backend. another big waste of time, albeit not OMEKA's fault.

Admin functions would work, but I'm just trying to put in about 20 paintings that I plan to sell, and wanted a system to help show this.
This "Dublin Core" stuff is foreign to me, but it makes me wonder why when viewing an item, I have to have "Dublin Core" staring me in the face all the time. I tried looking around to edit that crap out but couldn't find where.

Sorry, its just one thing after another.
I could get into the end-user side of the app by manually adding "index.php" at the end of the url. MOST functions worked, except the two nav buttons (browse items and browse collections) were coded differently and the URLs they produced failed. They didn't have "index.php" injected into them like many other links did, and I had no idea where to go hack that into the code.
I could have pasted all the data in one big .html file by now.


Other users have experienced problems with 1and1.com in the past. If you search back through the forum, you will see some of their issues and fixes.