1.4 upgrade

When upgrading from like 1.3.2 to 1.4 it only says "Public site is unavailable until the upgrade completes." Any ideas on why the upgrade is not working like usual?

You need to log into the admin dashboard and press the "upgrade" link to complete the installation.

I received the same error message and it didn't change when I pointed directly to "/admin."

I had just started experimenting with the previous version, so I deleted everything and started from scratch with 1.4. Still, I'm concerned about handling future upgrades.

I had the same problem when I tried to overwrite omeka 1.3 with 1.4. Make sure to move or delete old omeka directory before you upload new version.

Make sure to move or delete old omeka directory before you upload new version.

Yes! For certain versions, simply overwriting the old Omeka files with the new ones may work alright, but whenever we remove a file from Omeka or change a file's location, just overwriting your old installation won't completely bring you up to date, since you'll have old files floating around.

The documentation page on upgrading gives instructions for the "proper" process. Boiled down, you should move your existing Omeka folder to another name, unzip or upload the new Omeka, then copy back your config files and archive directory.

Is it possible to upgrade from 1.2.1 directly to 1.4.1? Or do I have to upgrade first from 1.2.1 to 1.3.2, and then (ugh) from 1.3.2 to 1.4.1?

You should be able to directly upgrade from 1.2.1 to 1.4.1.

The only "hiccup" in the upgrade process occurs when you're trying to go from a pre-1.2 version to a post-1.2 version.