News RC2

This week we have begun testing Omeka’s Release Candidate 2 in a private beta.

If you are interested in getting on the invitation list to download and test Omeka, please email us ( and we will notify you when there are additional spaces for this testing period. Because Omeka is in its early developmental stages, we unfortunately cannot offer support at this time.

As you think about how Omeka might be useful for your organization, please keep in mind the system requirements:

  • Linux operating system

  • Apache server (with mod_rewrite enabled)

  • Mysql 5.0 or greater

  • PHP 5.2.x or greater (with pdo_mysql enabled)

  • ImageMagick

Go back to news