Forums » Still getting 404s and whitepages with install

RSS feed for this topic

Info

  1. My sysadmin has set AllowOverrides ALL in httpd.conf, and I have checked that mod-rewrite is installed in my PHP config (http://www.manchester-press.com/test.php), but when I have the .htaccess file in my root folder, then nothing works: the omeka php files just give me the whitepage, and even test.php which I introduced doesn't work.

    Basically, I have the server configured as asked, and when I place the .htaccess file into the root folder, all of the php goes dead.

    I've also made sure that the .htaccess has the code telling php to give me error messages, but that does nothing at this point.

    what else can I ask my sysadmin to do? I check the error logs and all I get is stuff like this (only when .htaccess is present):

    [Tue Jul 22 18:57:28 2008] [error] [client 76.232.149.226] client denied by server configuration: /home/web/manchester-press.com/data/test.php

  2. Is this the line you have in your .htaccess to display errors?

    php_value display_errors 1

    Also, the .htaccess file for Omeka won't let you access scripts other than index.php, since the entire application is routed through that. To get around that in order to try loading a test.php file, you should comment out the following:

    <FilesMatch "\.(php|ini)$">
     Order Allow,Deny
     Deny from all
    </FilesMatch>

    Be sure to uncomment it again after you get Omeka working.

    One other thing I can think of is, try taking out the lines with php_flag zlib in them. Let me know if any of that helps.

  3. Kris:

    Thanks so much for the quick reply.

    I commented the FilesMatch section, and that got test.php to work with .htaccess present, but other than that, nothing has changed. I commented the zlib lines out, and I am still hitting a plain white page. I am not getting errors on screen, or in the logs.

    And yes, php_value display_errors 1 is in my .htaccess file.

    I am stuck.

    -Fritz

  4. I googled that apache error, and it may have something to do with your server settings not allowing access to that directory. I'm still not sure what would be wrong, but you could try adding something like this to your httpd.conf file:

    <directory /home/web/manchester-press.com/data>
    allow from all
    </directory>
  5. <Directory "/home/web/manchester-press.com/data">
        Options Indexes FollowSymLinks MultiViews Includes
        AllowOverride All
        Order allow,deny
        Allow from all
      </Directory>

    My sysadmin reports that the above is my entry in the .conf file. Is there anything in this that could be killing the omeka install?

  6. Fritz,

    Try adding this to the bottom of your .htaccess file.

    <Directory /home/web/manchester-press.com/data>
    Options -MultiViews -Includes -FollowSymLinks -Indexes
    Order Deny,Allow
    Allow from all
    </Directory>

    This will disable the options set in the apache conf file. This might be necessary because MultiViews, if it can't find a file or directory, kind of makes one up. You'll also want to disable Indexes, so that the directory structure is not visible. Includes (server side includes) are pretty insecure, so it's also best to disable those. You probably won't have any symbolic links to worry about, so it's safe to disable that as well.

    Let us know if that works or does not.

  7. I'm getting a 500 error that says <Directory not allowed in the .htaccess file. Is there another way to get those commands into the file without putting it into the directory tag?

  8. I'm giving up. I'll try this thing again next summer.
    Thanks,
    Fgs

  9. Fritz,

    A little Google searching turns up the Apache manual for using .htaccess files.

    http://httpd.apache.org/docs/2.0/howto/htaccess.html

    Give that a look over and see the section 'How directives are applied' for an example on how to get your 'Options' into the .htaccess file.

Reply

You must log in to post.