Forums » Some items display peculiarly after CSV import

RSS feed for this topic


  • Posted in Plugins
  • Started 5 years ago by gnosis_omeka
  • 6 posts by 2 users
  • Latest reply from gnosis_omeka
  1. Some items display peculiarly:

    Note: After import, I try to manually re-catalog problem item records by peculiar display continues.

    Here is a comprehensive list of all the problematic records:

    Any ideas?

    Records are form CSV batch import. Coudl there be something peculiar with the spreadsheet?

    Seems like most of the problem records do not display Subject Headings.

    There are Subject Headings in the Spreadsheet, but lost in the CSV import...

    Excuse cross postingss (not sure hwere to put this)

  2. That is very strange. Were there any extra symbols in those subject fields in the CSV files for those items that are breaking?

  3. Definitely not display based because no matter the template same issue.

    No extra symbols.

    In fact I thought maybe extra carriage return or something so I re-cataloged in and re-imported a few records and same result.

  4. Note, because I needed to re-oder the fields, I removed:

    and added added indiv fields:
    <?php echo item('Dublin Core', 'Title'); ?>
    and for subject array:
    <?php foreach ($subjects as $subject): ?>
    <li class="subject">
    <?php echo $subject; ?>

    <?php endforeach; ?>

    <?php endif; ?>

  5. I see that there is an open
    <li> tag in what you posted, and that there is a special class for subject. You don't need to paste in the page code, but if there is an open element on the page, it could be breaking the page layout. Maybe delete the <li class="subject"> in items/show and see if that fixes the problem.

  6. Thanks, Sheila. I aprpeciate it.

    Fixing the HTML didn't do it, so we just manually re-cataloged.

    Some how the CSV import hiccuped, because the missing subjects were not in the db.



You must log in to post.