Forums » Database upgrade not successful

RSS feed for this topic

Info

  1. I installed Omeka on Dreamhost with the 'One Click' install and everything was fine until I tried to upgrade my database. I received the error:

    Omeka encountered an error when upgrading your installation:
    Error in Migration #1
    Message: Migration file does not exist for #1!

    Any suggestions?

  2. What exactly was the process that you followed? Did you install Omeka 1.2 through the one-click and then upgrade to 1.3.2 on your own?

    Have you checked the db.ini file to be sure it contains the correct Dreamhost database info? We are trying to get Dreamhost to make the one-click a true one-click, because the process does not pre-populate the database information.

  3. I upgraded to 1.2.1 fine the old fashioned way (no one-click), and then decided to go ahead and hit the "upgrade" button and keep going after reviewing my exhibits, etc. When I hit the "upgrade" button I got the same message. I use GoDaddy, not Dreamhost, for what it matters. I'll try to check back if I find any great solutions.

  4. "Keep going" meaning that you tried to upgrade to a newer-still version?

    In other words, what version were you trying to upgrade from, and what version were you trying to upgrade to?

  5. Hi John, Sorry. I had successfully completed the upgrade to 1.2.1, but I did not complete the upgrade to 1.3.

  6. I did see another post in the forums about Alter privileges that has me wondering if it might be a solution...

  7. If you're looking to upgrade to the latest version (1.5) eventually, I'd recommend that you go directly from your current version to 1.5.

    The only "gap" where you need to make more than one step when upgrading is from pre-1.2 versions to 1.3 and up. In other words, you can directly go from your version, 1.2.1, to the current version 1.5.

    Lastly, you should be following the instructions on upgrading. Following those instructions should make sure you don't have any problems with having old migrations or other files from previous versions mucking things up.

  8. I am looking to go to 1.5 eventually!
    Despite spending a lot of time with the upgrade directions, reading what you've said, I clearly misunderstood the directions about the upgrade button, and I think I skipped steps thinking they were supposed to be done in a different order after 1.2.1 and the new upgrade button. I think you've given me some hope that I'll get to version 1.5 before Omeka 1.6 comes out! Thanks, John! I will try going directly to 1.5, it sounds much more practical!

Reply

You must log in to post.