Trouble installing 2.0 compatible plugins: "This is not a valid plugin"

Just started using Omeka with on a test site at my library and am having trouble installing several 2.0 compatible plugins. The plugins that are not working include: Beam me up to SoundCloud, and PBcore element set.

The message I receive is: "This is not a valid plugin".

Not sure what the issue is, but any help is appreciated.



Also, this one does not work either: Replace DC:Title in all public/admin views

It looks like the developer for those plugins just uploaded plugins directly from Github, which sticks some extra junk onto the plugin folder name.

I've replaced the latest versions of those plugins with updated zips that have corrected folder names. These should work correctly.

Thank you, John! All the plugins work now.