Timezone error message on install

I'm trying to get 1.3 up and running on Red Hat/Fedora. Everything appears to go well up through the point of entering the data into the install form. When I submit the form though I'm getting an error message concerning the time server that I'm not sure about. The time server on the system is set to synch with the Red Hat time servers.

Here's the error:

Fatal error: Uncaught exception 'Exception' with message 'DateTime::__construct(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected 'America/New_York' for 'EST/-5.0/no DST' instead' in /var/www/html/omeka/application/libraries/Omeka/Db/Migration/Manager.php:94 Stack trace: #0 /var/www/html/omeka/application/libraries/Omeka/Db/Migration/Manager.php(94): DateTime->__construct() #1 /var/www/html/omeka/application/models/Installer/Task/Migrations.php(23): Omeka_Db_Migration_Manager->markAllAsMigrated() #2 /var/www/html/omeka/application/models/Installer/Default.php(91): Installer_Task_Migrations->install(Object(Omeka_Db)) #3 /var/www/html/omeka/application/models/Installer/Default.php(55): Installer_Default->_setupMigrations() #4 /var/www/html/omeka/install/controllers/IndexControll in /var/www/html/omeka/application/libraries/Omeka/Db/Migration/Manager.php on line 94

This looks like it's coming from php, but I'm not sure how to fix it.

Once this happens, Omeka appears to the system to be installed, but the web server only serves up a page saying the system is offline at present.

I've done a complete removal and re-install with the same result.

Any suggestions greatly appreciated.

Bobb Menk
MIT Lincoln Laboratory Library

Ok I found where php.ini lives in Red Hat Enterprise Linux 6 - it's just in the /etc directory. I edited the ini to use an acceptable time zone value as follows:

'date.timezone = "America/New_York"'

That seems to get me past the page claiming I'm offline or upgrading.

Now I'm stuck at same re-direct loop mentioned by user aheadly in this post:

Mine is also a clean install of 1.3 and not an upgrade.

So I'm leaving this post here as a probable fix for others with the time zone error and will fervently hope for some assistance on the redirection problem.

Bobb Menk

The message you're seeing is a new requirement that comes from PHP 5.3.

Essentially, PHP wants you to specifically tell it what time zone your server is in.

You can do this by setting the date.timezone setting in php.ini, where you would add a line like:

date.timezone = America/New_York

If you don't have access to your php.ini file, you can also set the timezone in your .htaccess, by adding a line inside the IfModule block at the top of the file:

<IfModule mod_php5.c>
    php_value date.timezone "America/New_York"
    [.htaccess file continues...]

Yes, it looks like Bobb and I had the same exact problem. I would just mention for posterity that this timezone fix did not take for me until I restarted apache.