Thumbnails and images

I am using the Berlin theme and cannot figure out how to get the thumbnails or any size image of my files to show on the featured page or on the browse page or on the item page.

I think the problem is that Omeka isn't processing my jpg files. When I try to upload a jpg, I get the following error message:

Something went wrong with image creation. Please notify an administrator.

Sounds like an ImageMagick problem.

Did someone set up this installation for you? If so, check back with them to be sure they have ImageMagick installed properly, or check with your hosting service:

I installed ImageMagick with Macports. As far as I can tell, it is installed properly. I even checked to make sure it can process jpeg files and got this:

Can you access this link?

Can you try a image type other than JPEG, like PNG or GIF?

With the output you posted, a JPEG-only problem is unlikely (although a situation where you're using a different "convert" on the command line than you pointed Omeka to is possible).

The PNG and GIF didn't work. I can upload MOV and PDFs just fine, though I can't get them to display on the public view browse page (I think that's a separate issue).

Re: although a situation where you're using a different "convert" on the command line than you pointed Omeka to is possible

How do I verify that Omeka is communicating with ImageMagick properly? How do I know that Omeka knows where to find ImageMagick and is giving it the correct command? Is that what you mean?

You can run which convert in Terminal, which will tell you where the "convert" you ran on the command line is located.

The ImageMagick path in Site Settings should be the same (though without the "convert" part at the end).

I ran which convert and got:


In the General Settings page, I have entered that, but without the /convert
This is what it looks like:

By the way, thank you for chiming in and responding so quickly! I've been trying to figure out this issue for days. Hopefully, we'll figure this out!

Next thing to check would be permissions.

Again, in Terminal, run the following to see what the permissions for your temporary directory and the convert binary are:

ls -ld /private/tmp


ls -l /opt/local/bin/convert

These are the results for both prompts:

Also, not sure whether this matters, but I installed ImageMagick after installing Omeka.

Is there a way to check (or maybe reset to the default) the Omeka files having to do with converting images? Perhaps the issue lies there?

I let this alone for a while, and then just went back and tried to add a quicktime mov file to an item, which was working just fine earlier today. But when I tried it just now, rather than getting a message that the file uploaded successfully, I get sent back to the Edit Item page.

I should say that I performed a recent software update on my machine between the earlier attempt and this new one. Not sure if my updates may have disturbed anything.

Getting sent back to the Edit Item page with no message is usually a different problem: your PHP post_max_size setting is too small to accomodate the file you tried to upload.

Both the post_max_size and upload_max_filesize settings in php.ini need to be at least as high as the size of the file you're trying to upload.

Oh good. Thanks for that tip. I'll check the settings for file size.

As you suggested, I also ran these commands:
ls -ld /private/tmp
ls -l /opt/local/bin/convert

And this is what I got: