Simple Page: Content in Text Field Being Truncated

We are having a problem with one of our simple pages. The text is being truncated at a certain point in the Text field, almost as if there is a character or word limit. It simply won't allow the text at the end of the page to be saved. (You save it but it truncates at the same place each time you do).

Can anyone tell me why this may be happening?

So, are changes you make further up in the page being saved correctly, or is it just not saving your changes at all?

John, for some reason it seems to be working now. <Scratch of my head>

I did find out that our editor did cut some of the text. So, that might be the reason all the text now shows. My question remains: is there a character/word limit on these simple pages.

To answer your question, the text at the top of the page was saving correctly. It was the text at the end of the field that was being truncated. And truncated in the same place each time. When I went back into the backend, the text was also truncated in the field.

There should be no limit on the length of a simple page.

As a quick test, I just created a simple page with about 15,000 characters, which works fine.

At the extreme high end of length, you may run in to the limits of some PHP and MySQL settings, like the maximum size of a POST or the maximum size of a query, but Omeka doesn't impose any limit.

Well, how about 58,746 characters?

If Omeka doesn't impose any limit on the maximum size of the post (the issue is taking place on a "simple page" in Omeka) then there shouldn't be a reason for a problem. Is that correct?



Omeka does not impose maximum limits, but PHP does. Check the post_max_size directive. If your server has Suhosin installed, check the and suhosin.request.max_value_length directives.


Jim, where would I find the post_max_size directive and how would I know if Suhosin is installed? Thx.

They're found in your server's php.ini file. Or you can create a file on your web server containing the following code and run it in your browser:

<?php phpinfo(); ?>

Otherwise, I recommend you speak with your server administrator.