Problems with Zend and TMP directory when installing


I'm having poblems installing Omeka on a virtual host. I think the problem is related to SAFE MODE and Cache writing.

When trying to access the install script for the first time, I get:

Fatal error: Uncaught exception 'Zend_Cache_Exception' with message 'ACould not determine temp directory, please specify a cache_dir manually' in /home/snailand/www/museuarxiu/omeka/application/libraries/Zend/Cache.php:213 Stack trace: #0 /home/snailand/www/museuarxiu/omeka/application/libraries/Zend/Cache/Backend.php(203): Zend_Cache::throwException('ACould not dete...')

In another post, I read that the best option would be to ask my host to disable SAFE MODE, but unfortunately, I don't think it's possible. Is there any other way to solve this? Since this will be a small project, mainly a first testing of Omeka, I would be happy just disabling caching altogether. Is it possible? maybe easier?

Thanks a lot for your time,


Safe mode's not necessarily related to this problem, but it might be.

You simply need read/write access to some temporary directory on your server. Zend will check some environment variables, the "system" temp dir, the upload temp dir, and specifically the folder /tmp to see if you have the needed access to any of them.

Otherwise, you could hack the caching code out from application/libraries/Omeka/Core/Resource.php but this might not be the last of your problems on a server that doesn't give you even this amount of access.

I am receiving the same error ( and I am trying to set the path manually. My host indicated " /home/educacaoaberta/www/tmp/". What file should take this information?

Judging by your direct linking to "install.php," I'd also say your host doesn't have mod_rewrite set up correctly for you. You can bypass that check by going to "install/install.php" instead of just "install," but if mod_rewrite's not working, Omeka won't work properly either.

As for the temporary directory, Omeka 2.0 makes it a little easier to change these settings. The reason Zend is trying to use the temp directory is for caching locale/translation information.

You can turn that caching off entirely in application/config/config.ini by adding the following line:

locale.cache = ""

If you want to keep the caching (a good idea), and just change the directory, you can do that in config.ini also:

cache.locale.backend.options.cache_dir = "/home/educacaoaberta/www/tmp/"

This work, I have a new problem with "convert", but I thought it would need a new thread. The discussion is moved here.