Problem item import with Neatline


I just installed the latest versions of Neatline, Neatline Time and Neatlie Simile for Omeka 2.1.2.

Everything seems ok but the "import items" fonction only adds a few items (generaly 4 or 5)even when I choose to add a collection of a hundred items ...

Did someone have the same problem ?

Thanks a lot

Hey Percha,

Are you importing items into a Neatline exhibit, or onto a NeatlineTime timeline display?


Hi David,

i'm working on an exhibit. But i think there's also trouble with Netline Time...

Hm, that's odd, there are various configuration issues that can cause the imports to not work at all, but it's weird that it's importing some but not all of the items. Does it happen with all collections, or just one specific collection? I'm wondering if there could be something about the metadata in one individual item that's hitting a bug in Neatline, which they causes the import job to fall over.

Let me know!


Thanks for your help !

It makes the same thing with each or our collections. I tried to import items using keywords but it's the same problem...

Hey percha,

Apologies for the slow response here. This is weird, and I'm not totally sure what the problem is, but I suspect that something is going awry with the background process that actually performs the item import. To debug, let's try this:

1) Open up the Omeka configuration file at <omeka root>/application/config/config.ini.

2) Go down to line 167, which should look like:

jobs.dispatcher.longRunning = "Omeka_Job_Dispatcher_Adapter_BackgroundProcess"

3) Replace Omeka_Job_Dispatcher_Adapter_BackgroundProcess with Omeka_Job_Dispatcher_Adapter_Synchronous, the value used in the line above.

Save the file, and try running one of the imports again. Does that change anything?