Problem adding multiple files to an item

In the past, I have been able to add multiple files to items in my Omeka instance, but this has randomly stopped working, and I'm honestly not sure what changed.

The biggest thing is that we switched to a new custom theme that I wrote, but I'm not sure how or if this would affect the Admin screens. So far, I have not changed any files outside of /var/www/themes/ and /var/www/plugins for this instance.

Essentially, when I select a new file on my hard drive to upload and click the "Save Changes" button at the bottom, it dumps me back to the front edit page (/admin/items/edit/[insert item number here]) without actually having saved any of the changes.

I've made a Google Docs slideshow of screen shots with descriptions of what I'm doing. Please read the Speaker Notes for explanations. The slideshow is at:

Any help would be appreciated! Thanks in advance!

Are you having this problem only when uploading to items that already have an item, or also for new items?

The most likely cause of this problem, where you submit the item form and Omeka acts like nothing has happened is a problem with a PHP setting called post_max_size, which affects the size of files that you can upload. If you exceed this limit, you get behavior like you showed in your slideshow.

You can check this setting by looking at your php.ini file or by using the phpinfo() function.

We had changed upload_max_filesize but forgot about post_max_size. Both are now set to 200M (because we may be uploading some fairly large PDFs, video files, etc.). I'm now able to upload multiple files in some instances where I couldn't yesterday.

We are still having some trouble, though, and I'm finding now that it's not just limited to multiple file uploads. One PDF file that's been giving us a lot of the trouble is 8,768 KB in size. When I try to create a new item using this file, I get the same behavior: Omeka dumps me back at the starting item edit screen without having saved any changes.

Is there another setting that we have overlooked? Any advice on where to look next?

Thank you again!

Other than editing those two settings (of course, you need to make sure to restart Apache if you're using mod_php), I don't really have much specific advice. This is really a PHP issue more than it is an Omeka issue. However, do remember that you might want a larger post_max_size than your upload_max_filesize, since the POST size limit also includes any other data you're sending at the same time (in Omeka, this would mostly be the other metadata fields). I doubt that metadata is pushing you over your limit, but it's something to think about.

Also, it'd be a good idea to look through your server logs. While it may appear that nothing has happened, PHP will usually generate a warning or notice for something like this. If you look in your PHP error log, you should see some message that will point toward the problem. (Note: sometimes PHP errors are logged in the Apache error log, depending on your server settings.)

Thanks! I'll work with our server admin on this and report back if we find anything noteworthy.