Just curious, is it possible for Omeka to run using PHP 5.1.x? Searching through the forums, I found this comment:
"We currently list PHP 5.2.x as a system requirement, however we’re working on an overhaul of our database connections in the core code which will lower that requirement to 5.1.4 once completed – possibly by next month."
I attempted to install Omeka on a system running PHP 5.1.6, but the install screen tells me my PHP version is too low. If it is possible to use Omeka with this PHP version, is there a simple adjustment I can make somewhere?
If you’d like to override the 5.2.x system requirement, you can modify the verify.php in the ‘install’ directory. There you’ll see the 5.2.x version requirement, so you can lower that.
With that said, it’s unlikely that you’ll be able to get everything running properly. The forum message you dug up was 7 months ago during our Private Alpha testing stage, and much of the code has changed since then. You’re welcome to give it a try and let us know what you come up with, but we can’t formally support PHP versions below 5.2.x.
Thanks Dave. I edited the verify.php file from 5.2 to 5.1.x and it seems to be working like its normal awesome self. The Dropbox plugin is working also.
By the way, the reason for 5.1.x is because the academic institution where the Omeka site I'm installing runs Red Hat Enterprise Linux 5 and PHP 5.1.6 is what's available right now for that version of Red Hat. The IT department won't install PHP 5.2 from source so PHP 5.1.6 is all I have available to me. Fortunately it seems to be a go.