Omeka/mysqlnd error after upgrade on Mac to 10.6

I had Omeka working fine on Mac OS 10.5.
I upgraded to a new laptop with 10.6 and now I get:

Omeka Has Encountered an Error

mysqlnd cannot connect to MySQL 4.1+ using the old insecure authentication.
Please use an administration tool to reset your password with the command
SET PASSWORD = PASSWORD('your_existing_password').
This will store a new, and more secure, hash value in mysql.user.
If this user is used in other scripts executed by PHP 5.2 or earlier you might
need to remove the old-passwords flag from your my.cnf file

I've googled this error, but I don't understand where to apply the suggested fixes. ( mysql server or client )

Since this seems to be connected to new mysql access methods in php 5.3, I may try and see if I can downgrade to php 5.2
and see if that will fix the problem.

Any better suggestions ?

What the message is trying to tell you to do is to use a MySQL tool to change your password, since this will update it to the format that the newer mysqlnd library is expecting.

You should be able to fix this by first unsetting the old-passwords flag from your my.cnf file if it's set there. (I'm not entirely sure where that's located on your machine; it would depend on whether you're using MAMP or a downloaded MySQL package). This will stop MySQL from using the old-style password storage.

Then, all you need to do is reset your password. You should be able to do this from phpMyAdmin (there is a "change password" link on the front page). You can also do this directly through the mysql command-line interface (which you'd start by running the command mysql -u your_username -p in Terminal), by running the following query, as suggested by the message:

SET PASSWORD = PASSWORD('your_password');