Omeka PHP error on AMPPS

Hi. I have Omeka installed on a localhost setup Ampps. Both Omeka and Neatline installed fine with no problem. However, when I try to import items from Omeka into Neatline I get a PHP error. Other forum posts suggested finding the local path of the background.php and changing the config.ini file. However I am very unfamilar with PHP and can't find the right path. Does anyone have experience installing Omeka on Ampps? Or can tell me what I should look for in the php folders?
Many thanks from a techno-novice.

Could you follow this guide to showing error messages, then post up the error messages that appear? Thanks.

Omeka has encountered an error


The configured PHP path () is invalid.

#0 C:\Program Files\Ampps\www\omeka\application\libraries\Omeka\Job\Process\Dispatcher.php(94): Omeka_Job_Process_Dispatcher::_checkCliPath('')
#1 C:\Program Files\Ampps\www\omeka\application\libraries\Omeka\Job\Process\Dispatcher.php(28): Omeka_Job_Process_Dispatcher::getPHPCliPath()
#2 C:\Program Files\Ampps\www\omeka\application\libraries\Omeka\Job\Dispatcher\Adapter\BackgroundProcess.php(31): Omeka_Job_Process_Dispatcher::startProcess('Omeka_Job_Proce...', Object(User), Array)
#3 C:\Program Files\Ampps\www\omeka\application\libraries\Omeka\Job\Dispatcher\Default.php(150): Omeka_Job_Dispatcher_Adapter_BackgroundProcess->send('{"className":"N...', Array)
#4 C:\Program Files\Ampps\www\omeka\plugins\Neatline\controllers\ExhibitsController.php(154): Omeka_Job_Dispatcher_Default->sendLongRunning('Neatline_Job_Im...', Array)
#5 C:\Program Files\Ampps\www\omeka\application\libraries\Zend\Controller\Action.php(516): Neatline_ExhibitsController->importAction()
#6 C:\Program Files\Ampps\www\omeka\application\libraries\Zend\Controller\Dispatcher\Standard.php(308): Zend_Controller_Action->dispatch('importAction')
#7 C:\Program Files\Ampps\www\omeka\application\libraries\Zend\Controller\Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
#8 C:\Program Files\Ampps\www\omeka\application\libraries\Zend\Application\Bootstrap\Bootstrap.php(97): Zend_Controller_Front->dispatch()
#9 C:\Program Files\Ampps\www\omeka\application\libraries\Zend\Application.php(366): Zend_Application_Bootstrap_Bootstrap->run()
#10 C:\Program Files\Ampps\www\omeka\application\libraries\Omeka\Application.php(79): Zend_Application->run()
#11 C:\Program Files\Ampps\www\omeka\admin\index.php(28): Omeka_Application->run()
#12 {main}

Yeah, that does look like the path issue.

From the command line, if you do

which php

that should tell you the correct path.

Then, in /application/config/config.ini look for this line and put in that path

background.php.path = ""

I'm probably doing this wrong, as I can't get any php command to work in the command line. I have three php folders in my Ampps installation:
Should I just try these as the paths? I've tried to read how to get to PHP command line correctly but it doesn't seem to work. I just get a blinking cursor and "where php" doesn't work.
Sorry again, this might be over my head.

Is this AMPPS for windows, mac, or linux?

I had assumed linux, so if that's wrong that might be part of the problem.

Might be worth trying those as the path. You'll need to use the complete path, starting at the very top directory

AMPPS on Windows.
I tried adding multiple paths, but nothing worked. I am not sure of the format to use?
Should it include the exe file? or just be to the folder?
C:\Program Files\Ammps\php\php.exe
C:\Program Files\Ammps\php\

I keep getting the same error. Maybe Ammps isn't compatible with Neatline? I went with it because I thought both Omeka and all plugins would work on local host.

If you are using this installation for development, you might consider using the Omeka Turnkey appliance in Virtual Box and upgrading it to the most recent version (it's still on Omeka 2.0.1). Doing so avoids all of the potential configuration problems with the various *AMP* stacks for Windows.

Set it to /Applications/AMPPS/php

You'll also need to turn on a couple of php extensions like ctype and iconv from the php tab in the AMPPS control app, and restart Apache.