Omeka on XAMPP

I've successfully installed XAMPP on my Windows 7 machine, and it seems like I've installed Omeka in the correct location. However, I've gotten this error message:

"Omeka has encountered an error

To learn how to see more detailed information about this error, see the Omeka Codex page on retrieving error messages."

I've checked the codex page and done what they have suggested, but no luck. Do you guys have any suggestions?

If you've successfully done the steps on that codex page, you should be getting more messages. could you post up the additional info?

Hello patrickmj!
I've removed the # from the .htaccess file, so it looks like this now:

# Omeka .htaccess: Apache configuration file
# This file is required for Omeka to function 


# --------------- #
# Error Reporting #
# --------------- #

# Uncomment the SetEnv 

line below to turn on detailed on-screen error
# reporting.
# Note: This should only be 

enabled for development or debugging. Keep this
# line commented for production sites.  SetEnv 


# ------------- #
# Rewrite Rules #
# ------------- #



# If you know mod_rewrite is enabled, but you are still getting mod_rewrite
# errors, 

uncomment the line below and replace "/" with your base directory.
# RewriteBase /

# Allow 

direct access to files (except PHP files)
RewriteCond %{REQUEST_FILENAME} -f
RewriteRule !

\.php$ - [C]
RewriteRule .* - [L]

RewriteRule ^install/.*$ install/install.php [L]

^admin/.*$ admin/index.php [L]
RewriteRule .* index.php

# -------------- #
# Access Control #

-------------- #

# Block access to all .ini files.
<FilesMatch "\.ini$">
    Order Allow,Deny

Deny from all

# --------#
# Caching #
# --------#

# Uncomment the lines below in 

order to enable caching of some files
# (after a finished site has gone live)
# <IfModule 

#    <FilesMatch "\.(js|ico|gif|jpg|png|css)$">
#        ExpiresActive on

 ExpiresDefault "access plus 10 day"
#    </FilesMatch>
# </IfModule>

# ------------ #
# PHP 

Settings #
# ------------ #

<IfModule mod_php5.c>
    php_flag register_globals off

magic_quotes_gpc off

I've also attempted to change debug.exceptions = true; to the config.ini file.

with those changes, you should be seeing more of an error message, and you should also be seeing info going into application/logs/errors.log -- is there still nothing showing up in either place?

I just checked it and there's nothing logged there, unfortunately. However, I must mention that there was one point when I changed one of the files and I received a 500 Server Error... I just can't duplicate the error now for some reason.

Hmm...that sounds like a place to start. If you remember the name of the file, you could always replace it from what's in the zip file. If you don't remember the name, you could replace all of the files.

I'm sure I only messed with the config.ini file and the .htaccess file. So I've reinstalled Omeka onto XAMPP. I've removed the # sign from that one line, #SetEnv APPLICATION_ENV development, and this is what I get now:

Omeka Configuration Error

Your Omeka database configuration file has not been set up properly. Please edit the configuration and reload this page.

If I add the # sign again, the original error message appears. If I edit the config.ini file, nothing new happens. I tried to enable errors logging in there, but it seems like the errors.txt file isn't recording anything.

Thank you so much for your time, by the way! I really appreciate it!!!

It's not config.ini that's the problem the error message is talking about, it's db.ini.

Check your db.ini to make sure it's in the right place and that all the required information is filled in.

Yep! That's what it was... I didn't have that file set up! Thank you so much, John Flatness. I successfully created a new database for Omeka and entered in the required information.

Now I have a new error message haha:

Installation Error
mod_rewrite is not enabled.

Apache's mod_rewrite extension must be enabled for Omeka to work properly. Please enable mod_rewrite and try again.

Time to look into this one...

I've read that I might need to change RewriteBase in the .htaccess file. If the address for the site that I am working with is a localhost site, having the address: http://localhost/omeka-2.0.4/

Would I need to change it to: RewriteBase /omeka-2.0.4/ ?

Before that, the thing to check is whether the server is set up to use mod_rewrite. It'll be in XAMP's server configuration. Sorry, don't know off the top of my head the file to look for, but in the meanwhile a google search might get you to the info you need: "Xamp mod_rewrite enable"

From what I've seen, there are a lot of variations, and different hits on that search yield varying results.

I found this link here:

From that, I think it's the httpd.conf file, located under C:\xampp\apache\conf\httpd.conf

I found this line: #LoadModule rewrite_module modules/ and it was already uncommented.

And I found one instance of AllowOverride None in <Directory "C:/xampp/cgi-bin"> and changed it to AllowOverride All.

Any different results after those changes? There might be other places to look for AllowOverride, maybe something that looks closer to the local path to where your Omeka installation is.

Nope, no different results after trying that. I still get this error:

Installation Error
mod_rewrite is not enabled.

Apache's mod_rewrite extension must be enabled for Omeka to work properly. Please enable mod_rewrite and try again.

Maybe if I try looking around the install folder? I've noticed that my localhost site keeps redirecting me to this path: http://localhost/omeka-2.0.4/install/... hmmm...

That's where Omeka's scripts to install are, but the real issue is with the server configuration. Sometimes the AllowOveride directive is set for different specific directories. Look for one of those that is specific to the directory where all of the web files are.

Hmm... Under the omeka-2.0.4 folder, I've checked the files .htaccess, bootstrap.php, db.ini, index.php...

And I'm sure I have my db.ini file set correctly. The database I created is called omeka:
host = "localhost"
username = "root"
password = ""
dbname = "omeka"
prefix = "omeka_"
charset = "utf8"
;port = ""

Should I be looking more in the files specific to folders under omeka-2.0.4 or general files under C:\xampp\htdocs? I see the admin, application, files, install, plugins, and themes folders under omeka-2.0.4.

Getting the same results. Any resolution ever found?