"Omeka has encountered an error" after 'successful' install

Hi, I'm trying to install Omeka as per the instructions in the pdf here:


I'm installing onto a Ubuntu Lucid VM that I have been provided. I've installed:


I've run the instructions as a different user to that detailed in the pdf, but have created the same account and added it to the webdev group.

Upon accessing the installation for the first time I am directed to /install - I fill in the details and get "Omeka is installed. You may remove the "install" directory for security reasons. Check out your site, or visit your admin panel"

Clicking either link produces: Omeka Has Encountered an Error

I understand that this is often a db problem, but I don't know why it's happening at this point. If I drop my omeka db and recreate it, for example, I'm taken back to the /install directory upon visiting the site. Likewise if I change any settings in db.ini I get the same error.

Are the instructions I have still relevant? Have I simply messed it up somewhere?

Thanks, Joseph

Follow the instructions on the Omeka Codex on retrieving error messages.

In particular, the "Display Error Messages" section will cause that page to show a more detailed message about the specific problem you're having.

Great, thanks, looks like a permission error?

Zend_Session::start() - /var/www/application/libraries/Zend/Session.php(Line:480): Error #2 session_start(): open(/var/lib/php5/sess_7ce891eck9f9hu2fkst90gglt7, O_RDWR) failed: Permission denied (13) Array /var/www/application/libraries/Zend/Session.php(Line:490): Error #2 session_write_close(): open(/var/lib/php5/sess_7ce891eck9f9hu2fkst90gglt7, O_RDWR) failed: Permission denied (13) Array /var/www/application/libraries/Zend/Session.php(Line:490): Error #2 session_write_close(): Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/lib/php5) Array

#0 /var/www/application/libraries/Zend/Session/Namespace.php(143): Zend_Session::start(true)
#1 /var/www/application/libraries/Zend/Auth/Storage/Session.php(87): Zend_Session_Namespace->__construct('Zend_Auth')
#2 /var/www/application/libraries/Zend/Auth.php(91): Zend_Auth_Storage_Session->__construct()
#3 /var/www/application/libraries/Zend/Auth.php(141): Zend_Auth->getStorage()
#4 /var/www/application/libraries/Omeka/Core/Resource/Currentuser.php(32): Zend_Auth->hasIdentity()
#5 /var/www/application/libraries/Zend/Application/Bootstrap/BootstrapAbstract.php(676): Omeka_Core_Resource_Currentuser->init()
#6 /var/www/application/libraries/Zend/Application/Bootstrap/BootstrapAbstract.php(619): Zend_Application_Bootstrap_BootstrapAbstract->_executeResource('currentuser')
#7 /var/www/application/libraries/Zend/Application/Bootstrap/BootstrapAbstract.php(579): Zend_Application_Bootstrap_BootstrapAbstract->_bootstrap(NULL)
#8 /var/www/application/libraries/Zend/Application.php(347): Zend_Application_Bootstrap_BootstrapAbstract->bootstrap(NULL)
#9 /var/www/application/libraries/Omeka/Core.php(114): Zend_Application->bootstrap()
#10 /var/www/index.php(30): Omeka_Core->initialize()
#11 {main}


This is a PHP configuration problem on your system (php.ini).

session.save_path looks like it's set to '/var/lib/php5'. PHP needs to have access to write to that directory, which in this case means that Apache needs to have access.

Perfect, thanks. That's working now.

Cheers, Joseph