Omeka 2.x / Ubuntu VMWare Installation Guide - Not Working

Installed on Windows Server 2012 (Virtual)


From the Guide:


host (server) name
primary user
mysql root password

Create mysql database

Download and Install Support Files & Omeka:


sudo aptitude install unzip
sudo aptitude install imagemagick
wget omeka
unzip omeka
sudo mv omeka /var/www/

NOT working
sudo mv omeka/.htaccess /var/www/
("No such file or directory")

sudo groupadd webdev
sudo usermod -a -G webdev user
cd /var

NOT working
sudo chown -R root.webdev www
("No such file or directory")

sudo chmod 775 /var/www
sudo find /var/www -type d | zargs sudo chmod -R 775

NOT working:
sudo find /var/www -type f | zargs sudo chmod -R 664
("sudo: unable to execute /bin/chmod: Argument list too long")

Not Working:
sudo rm /var/www/index.html
(File not found)

cd /var/www
sudo chmod -R 777 files

sudo nano /var/www/db.ini
and mods
sudo a2enmod rewrite

NOT working:
sudo nano /etc/apache2/sites-available/default
(File not found)


sudo nano /etc/apache2/sites-available/000-default.conf

Contents of 000-default.conf:

# The ServerName directive sets the request scheme, hostname and port that
# the server uses to identify itself. This is used when creating
# redirection URLs. In the context of virtual hosts, the ServerName
# specifies what hostname must appear in the request's Host: header to
# match this virtual host. For the default virtual host (this file) this
# value is not decisive as it is used as a last resort host regardless.
# However, you must set it for any further virtual host explicitly.

ServerAdmin webmaster@localhost
DocumentRoot /var/www/html

# Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
# error, crit, alert, emerg.
# It is also possible to configure the loglevel for particular
# modules, e.g.
#LogLevel info ssl:warn

ErrorLog ${APACHE_LOG_DIR}/error.log
CustomLog ${APACHE_LOG_DIR}/access.log combined

# For most configuration files from conf-available/, which are
# enabled or disabled at a global level, it is possible to
# include a line for only one particular virtual host. For example the
# following line enables the CGI configuration for this host only
# after it has been globally disabled with "a2disconf".
#Include conf-available/serve-cgi-bin.conf

<Directory /var/www/>

Options Indexes FollowSymLinks MultiViews

AllowOverride ALL

Order allow,deny

allow from all


sudo nano /var/www/.htaccess

Contents of .htaccess:

# Omeka .htaccess: Apache configuration file
# This file is required for Omeka to function correctly.

# --------------- #
# Error Reporting #
# --------------- #

# Uncomment the SetEnv line below to turn on detailed on-screen error
# reporting.
# Note: This should only be enabled for development or debugging. Keep this
# line commented for production sites.
# SetEnv APPLICATION_ENV development

# ------------- #
# Rewrite Rules #
# ------------- #

RewriteEngine on

# If you know mod_rewrite is enabled, but you are still getting mod_rewrite
# errors, uncomment the line below and replace "/" with your base directory.
# RewriteBase /

# Allow direct access to files (except PHP files)
RewriteCond %{REQUEST_FILENAME} -f
RewriteRule !\.(php[0-9]?|phtml|phps)$ - [C]
RewriteRule .* - [L]

RewriteRule ^install/.*$ install/install.php [L]
RewriteRule ^admin/.*$ admin/index.php [L]
RewriteRule .* index.php

# -------------- #
# Access Control #
# -------------- #

# Block access to all .ini files.
<FilesMatch "\.ini$">
Order Allow,Deny
Deny from all

# --------#
# Caching #
# --------#

# Uncomment the lines below in order to enable caching of some files
# (after a finished site has gone live)
# <IfModule mod_expires.c>
# <FilesMatch "\.(js|ico|gif|jpg|png|css)$">
# ExpiresActive on
# ExpiresDefault "access plus 10 day"
# </FilesMatch>
# </IfModule>

# ------------ #
# PHP Settings #
# ------------ #

<IfModule mod_php5.c>
php_flag register_globals off
php_flag magic_quotes_gpc off

sudo service apache2 restart

At first the Apache default page worked.

I added:

<Directory /var/www/>

Options Indexes FollowSymLinks MultiViews

AllowOverride None

Order allow.deny

allow from all


and that broke it.

Just took that out.

I've tried every which way to doublecheck the IP address and so on. Nothing but the Apache Startup page.

I'm stuck.


Here's what I get when I restart Apache:

techsupt@omeka:/etc/apache2/sites-available$ sudo service apache2 restart

* Restarting web server apache2
AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using Set the 'ServerName' directive globally to suppress this message
[Wed Oct 29 16:23:37.208080 2014] [core:error] [pid 6073] (EAI 2)Name or service not known: AH00549: Failed to resolve server name for (check DNS) -- or specify an explicit ServerName

The instructions you're using were contributed by another user, and probably corresponded to the state of things on the Ubuntu version they were using when they wrote the guide.

The one thing I immediately notice: the server is configured to serve files out of /var/www/html, not /var/www. This is probably the main source of your issues, you're not putting Omeka in the place your server is looking for files.

Well, I've tried moving everything into the



Still just getting the Apache page.

Changed the



to read


instead of


now the index.html file works.

Can't delete it.

Still just the Apache default page.

Or should I just begin over, although,
I'm not sure how to.

Ok, I deleted everything. Reinstalled.

Now I get this:

Omeka has encountered an error

To learn how to see more detailed information about this error, see the Omeka Codex page on retrieving error messages.

went to this page:

uncommented the following line:

# SetEnv APPLICATION_ENV development

in .htaccess

the other suggestion:

Activate Error Logging

If you'd prefer to not have your error messages publicly displayed on your site, you can instead activate error logging. Activating error logging will log any errors encountered by Omeka to a file in 'application/log' directory of Omeka. You can then post to the forum or email directly to us.

Change permissions on your installation so that the following file is writable by your webserver: application/logs/errors.log
Edit your application/config/config.ini file and change the value of log.errors to true.
Do your best to repeat whatever originally caused the error, then send us the relevant contents of the errors.log file.

Don't understand. So no action there.


Now shows


rather than


Ok, played with the application/logs/error.log settings.

Nothing in error.log