Forums » mod_rewrite is not enabled

RSS feed for this topic

Info

  1. I'm trying to get Omeka uninstalled under Leopard. When trying to do the install step from the browser, I get
    Installation Error

    Before installation can continue, the following errors must be resolved:

    mod_rewrite is not enabled

    Apache's mod_rewrite extension must be enabled for Omeka to work properly. Please enable mod_rewrite and try again.

    I verified that I have the line uncommented.

    I noticed in the apache2 console this error:
    File does not exist: /Library/WebServer/Documents/omeka/install/checkModRewrite.html

    I checked and it is true that file doesn't exist. Should it?

    I've seen comments about .htaccess files. I have one in /Library/WebServer/Documents/omeka

    It looks like this
    <IfModule mod_php5.c>
    php_value display_errors 0
    php_flag register_globals off
    </IfModule>

    RewriteEngine on
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d [OR]
    # This ensures that Apache will not mistake the URL mysite.com/archive/ for a re
    quest for the physical directory that stores files
    RewriteCond %{REQUEST_URI} .+\/archive\/
    RewriteRule !\.(js|ico|gif|jpg|png|css)$ index.php

    <FilesMatch "\.(php|ini)$">
    Order Allow,Deny
    Deny from all
    </FilesMatch>

    <Files index.php>
    Allow from all
    </Files>

    # Uncomment the lines below in order to enable caching of some files via Apache
    (after a finished site has gone live)
    <IfModule mod_expires.c>
    # <FilesMatch "\.(js|css|gif|png)$">
    # ExpiresActive on
    # ExpiresDefault "access plus 10 day"
    # </FilesMatch>
    </IfModule>

    Should this file be other places too?

  2. I meant installed not uninstalled. Whoops.

  3. mod_rewrite is a bit of a pain to get working on Leopard. Did you restart Apache after uncommenting the line for mod_rewrite? You have to do that I believe before the changes can take effect. You also need to make sure to change AllowOverride to All.

    I've got a small explanation on my personal wiki - http://clioweb.org/wiki/Leopard_Developer_Environment#5._Enable_mod_rewrite.

    Let me know if this helps!

  4. Thanks for replying.
    I did restart apache and have AllowOverride to All.

    I'll take a look at your wiki to see if I missed something.

  5. Ah, there was more than one place that had a line with phrase AllowOverride. I changed the wrong one. Fixed that using your wiki info and I'm going forward again.

    Thanks!

The forums are closed to new posts. To post new topics and read the latest discussions, please see the new forums.