mod-rewrite not enabled problem

I've been using Omeka from a local install without any problems. I'm now trying to install it with hosters Heart Internet. They meet all minimum specs (including mod-rewrite which I've checked is enabled).
Problem is I'm still getting 'mod_rewrite is not enabled' as Omeka install begins. I've tried suggestions from this forum (changing RewriteEngine 'on' to 'ON' and specifying RewriteBase locations within the various .htaccess files) all to no avail.

Hi Stephen,

How have you checked that mod-rewrite is enabled? Depending on the level of access you have to your server, you may want to double-check this by looking at your httpd.conf file on your server, and making sure that AllowOverride is set to All.

Jeremy wrote up some instructions for doing this on his local apache instance which may be of help:

Hi Dave,
thanks for the reply. I ran the php at: to test for mod-rewrite enable and it showed as positive. Maybe this isn't conclusive though? I don't have sufficient access to get to the httpd.conf. Is there a fool proof way to to check that both mod-rewrite is enabled and AllowOverride is set to 'All'? I've asked for clarification from Heart, but their customer service team seem to have taken an early Christmas break! Thanks

That's helpful for you to share.

What did you previously set the RewriteBase to? How about you try this.. set the RewriteBase immediately below "RewriteEngine On" in your .htaccess files. The rewriteBase will be different, depending on which folder you're in.

So, in the root of your Omeka install, the .htaccess file should have a RewriteBase set to "RewriteBase /", in the install directory: "RewriteBase /install/", and the admin directory, "RewriteBase /admin/".

Thanks again for the reply. I've checked that all the .htccess files have the lines you suggested. They do, but still the same error shows up.

Started from scratch with Blushost only to hit the same problem! Bluehost say mod-rewrite is enabled, but I still get the same error 'mod_rewrite is not enabled'. RewriteBase is correctly referenced in each of the .htaccess files. Ready to try anything that's suggested!

Solved it! As the domain was new I was operating with a temporary domain name (an IP followed by my username). When the real domain name kicked in Omeka was no longer confused and installed fine. Whew!


Do you have a public URL for your site? Those RewriteBase rules depend on the path to your installation. If you're installing Omeka at the root of a domain, those are correct. If, however, you're installing Omeka in a directory (like, you may have to include that directory in the RewriteBase rule (RewriteBase /omeka/).