ItemOrder plugin active, but not working

ItemOrder was installed yesterday, but no matter how often I drag and drop things around, nothing changes! Not in the admin, not on the public display.

Am I correct in believing there is no 'save' button or similar? I have tried from three different browsers, as sometimes they have a mind of their own, but no result.

Could you advise please?

What Omeka and ItemOrder versions are you using? What browser and browser versions are you using?

Changes are saved automatically. You're probably experiencing a JavaScript error. While on the item order page open up your browser's JavaScript console and drag and drop a few times. If you see a JavaScript error in the console, I'd like to see it.

Hi, thanks for getting back.

I have just had an upgrade to Omeka 1.5.1 installed, plus ItemOrder 1.0. I have tried Chrome, Safari 5.0.6 and Firefox 3.5.2

I tried to make chances with the Java console open in all three browsers and only with Firefox did I get an error message:

Warning: Unknown pseudo-class or pseudo-element 'data'.
Source File:

Would this imply that the upgrade of Omeka or install of ItemOrder did not work?


I can't reproduce the error. What operating system are you using?

Remember that the plugin only affects the order of items when browsing the collection. It has no affect on the global item browse. Try

I use Mac OS X version 10.5.8.

We tested it on OS X 10.6 and it works fine. jQuery, the JavaScript library that powers the plugin and many other parts of Omeka, may not be compatible with your OS/browser combination.

Would you confirm that your custom order is not preserved when browsing collection items?

Ah, I think I found the reason (or at least the cause) of the problem. The ItemOrder does work for parent collections, but not for child collections (as set in CollectionTree).... I.e. if I custom order 'archives' (which is a parent collection), the order is preserved. But if I custom order 'Ellison Family Papers' (which is a sub collection under 'archives', the order is not preserved.

Would there be a way around this (other than making every sub collection a main or parent collection)?


You discovered a bug in ItemOrder! Expect a bug fix release within the week. Thanks for your help on this.

I did? Oh, glad to be of help ;-)!

I'll await the bug fix.

The bugfix release (1.0.1) is ready for download:

Thank you for the bug fix release. It was installed last week and tested today. Unfortunately the ItemOrder still doesn't work for sub-collections when accessing them through collection-tree. Should that be possible in the first place?

That all should work. Since updating the plugin files, have you gone into the plugin's admin settings and upgraded it from there? Seems possible that you just need to click the "upgrade" button in the plugin panel.

Hi Sheila,

I have installed, upgraded and activated! After your post I actually uninstalled and did everything again, just to be extra sure. It still doesn't work.

I am at a total loss, especially since now the link between browse list and individual items seems to be lost in browse collections (goes to the entire browse list instead), but not in CollectionTree...

Is there any code you may need to see what may be causing the problem?

As an example: is a small sub collection, which can be found via CollectionTree. To test ItemOrder I moved ARM WFAE 3.3P up to the top. It does not appear there however. When I open the ItemOrder admin page again, the order has been put back to the original, even though I do not click that particular button.

Thank you for your help.

We'll look into this and get back to you shortly. Thanks for your patience.

I'm not sure it'll fix the problems you're having, but we just released a new version of the ItemOrder plugin (1.0.2): It fixes some bugs that I noticed while troubleshooting your issue. Let's hope for the best.

Thanks. I'll ask IT to install the new version!

I have been working with the new version (1.0.2) now for half an hour, and hey ho, it works! Thank you very much!

That's a relief. Thanks for sticking with it.