Infamous Pink Tiles on Neatline

Hi folks,

We are working on putting a custom map into our Neatline exhibit. We have successfully "published" the map as a layer in geoserver, the following directions here:

When we try to connect this to the Neatline exhibit, though, we end up with pink tiles (with broken image icons). Only a blank white screen is visible at the default viewpoint, but only when the map is zoomed out to encompass nearly the whole world (or what would be the world if anything showed up).
There doesn't seem to be consensus on whether the pink tiles reflect a problem with the file we're using, or with the wms address or layers we have entered into the Exhibit Settings. (Either is very possible, as all of this is new to us.)

Could someone explain in more detail where we might find (or how we might determine) the correct wms address to enter? The address that looks the most like the examples we've seen on other forum discussions comes from clicking the "openlayers" link for our chosen layer/map/image (under Layer Preview on Geoserver) and then deleting most of the details to end up with (sf is the workspace where the file is).

For what it's worth, these are some things that I (in my ignorance) noticed as possibly suspicious as I uploaded to geoserver: 1) When I click the “compute from data” link (as specified in the instructions), none of the numbers changed (they did when I clicked "compute from native bounds"). 2)There is no “alpha band” for my file listed on geoserver. 3)There are also no metadata links. 4) "Default wms path” (under "publishing" for the layer) is blank.

Also, I have tried viewing the resulting exhibit with different browsers, with the same result.

I realize others have been dealing with this question, but I haven't been able to find an actual solution anywhere. Sorry if I'm being repetitive, and thanks for any pointers!


Hi Abigail,

Can you try forcing the projection of the layer you're using to be EPSG:4326 in the Geoserver admin panel and trying it again? It's in the layer settings...


Hi Wayne,

Thanks for such a quick reply!

I think we've already done that, though I could be wrong -- under "Coordinate Reference Systems" the "Native SRS" is EPSG:4326 (and the "Declared SRS" is EPSG:900913, with "Force Declared" selected).

The extra information next to the Native SRS box says this:
DATUM["World Geodetic System 1984",
SPHEROID["WGS 84", 6378137.0, 298.257223563, AUTHORITY["EPSG","7030"]],
PRIMEM["Greenwich", 0.0, AUTHORITY["EPSG","8901"]],
UNIT["degree", 0.017453292519943295],
AXIS["Geodetic longitude", EAST],
AXIS["Geodetic latitude", NORTH],

Does it seem like we are "forcing the projection layer" by doing that?


Try setting both to 4326...

Aha! The magic numbers! That did indeed make the map show up. Thank you!

The only problem is that now, the points we've already entered no longer show up. When I enter new ones, they show up on top of the map layer, but we've already entered quite a LOT of records on the regular google basemap, so we'd like to be able to see those as well. Is there a way to make that happen? It's probably worth noting that the original base layer of the map, over which we were trying to lay the historical map, no longer shows up either (it seems that in other exhibits it does, outside the edges of the historical map). This is true regardless of how many "active map layers" I put in the editor, and regardless of what I put as the "default map layer." On the neatline map, if I click on the little "layers" icon the only thing that shows up is "Base Layer: French of Italy Timeline." Should there be more options there?

Am I missing something basic?

Is there a public version available to look at? We've seen issues with base maps with different projections, but there could be numerous other things going on too...


I've made it public temporarily; hopefully this link works:

Thanks so much for sticking with this!

Hi Abigail,

Do you need to have the base layer as this map, or could you use a different base layer (e.g. OSM) and layer this map on it? I suspect what's going on is a projection issue...


Hi Wayne,

We wouldn't mind having a different base layer, as long as this map somehow appears below the points. If I make OSM the "default map layer" and/or the "active map layer" (we've tried different combinations of layers), we're still ending up with the same thing: our map image appears, but none of the points or the surrounding map we might expect from the "active layer". It's like our image has overridden everything else, including the default layers. I'm not sure if that's what you mean by layering this map on top of one OSM, though.


Just for the information of anyone with the same problem, we did find a solution. Predictably, it was very simple, and probably someone could have explained it to us in a heartbeat if we had understood what to ask.

We were putting the WMS address and layers in the place for that on the Exhibit Settings. As I understand it, our map was overriding everything else we had put on Neatline, and was not equipped to quite do the job of a map.

When we made a new record in Neatline, and put the WMS address and layers in the appropriate fields under the style tab for that record, the map showed up and worked fine.

Thanks for all the help along the way, and sorry we were mostly chasing rabbit trails in our questions.