Indexing Timeout and Error

I have been trying to index my site, but when I click on index it never connects. The process is timing out. I receive this error message:

Fatal error: Maximum execution time of 30 seconds exceeded in /home/alplmc5/public_html/chroniclingillinois/application/libraries/Zend/Db/Select.php on line 1004

Any thoughts on how to resolve this?

Thank You,


That sounds like it is trying to run a long-running script synchronously, instead of in the background. Check in application/config/config.ini if there's a line like this:

jobs.dispatcher.longRunning = "Omeka_Job_Dispatcher_Adapter_BackgroundProcess"

These are the lines I see. Is this correct? Thanks, Patrick.


; Path to PHP-CLI for running background processes.

; default: ""


; If left blank, Omeka will try to autodetect the right path. Set this

; to override the autodetected PHP path.

background.php.path = "/usr/bin/php-cli"

; jobs.dispatcher

; How Omeka "jobs" will be executed.

; default: "Omeka_Job_Dispatcher_Adapter_Synchronous"


; Newer Omeka features and plugins use this setting to determine how

; long-running jobs will be run.


; The default setting should work for all installations, but may

; time out for longer jobs. On systems where the older PHP background

; processes worked, the BackgroundProcess adapter can be used instead

; of the Synchronous one.

jobs.dispatcher.default = "Omeka_Job_Dispatcher_Adapter_Synchronous"

jobs.dispatcher.longRunning =

;jobs.dispatcher.longRunning = "Omeka_Job_Dispatcher_Adapter_Synchronous"

Hmm, that looks right, basically.

You see that error in your browser, or in a log somewhere? Does the page take roughly 30 seconds to respond? If the browser is sitting blank or loading for about 30 seconds after you click the button, that would be a sign that the reindex actually isn't using the background process.