how to get non DC fields to display

I am new to Omeka so I'm not quite sure what it is that I am not understanding. I have looked at the documentation.

I have imported a cvs file and linked some of the fields to the DC core. However many of the fields don't have a matching DC core field.

These non-matching fields don't display. When I look at the forum for information I see a little information about changing the code on certain pages. Is that the way to do it?

I don't mind doing that but it seems like setting which fields should display is a basic part of a cms so I wonder if I am missing something.

Thanks for any help you can give me.

Michael Bannister

Did you map those fields from your CSV to anything on the Omeka site?

Thanks for your reply. I have not because I couldn't find the right field names when I tried to import my file. But thanks to your question I think I understand what I need to do.

Each item type has a set of elements/fields connected to it. And I can add elements to an "item type" by editing it in the "Item Type" section. That element will them show up as an match-up option when I import the cvs file.

I tired this and it seemed to work.

Thank you.
Michael Bannister

That was exactly what I was about to suggest - by adding a custom item type, you create the fields you need.