Exhibit Builder displays HTML tags

After the upgrade to the new version, the exhibit pages display HTML tags, e.g. putting <p> and </p> before and after text, etc...

As I stated in my other related post, I will try updating Omeka to see if that helps.

Hi Erin,
Are you now working in the latest release, 1.0? We did have that problem with the beta but it was fixed for 1.0.

I am having the same issue, and currently working on it. Running the latest version.

I re-installed the latest Omeka/ExhibitBuilder releases and it's still happening.

See here: http://tinyurl.com/mlesmn

I would also like to make mention that the error only persists on exhibit page layouts other than the text-only option.

Any word on how to fix this bug. As far as I can tell, the HTML tags are only showing up in the 4 image-list layouts.

A bug fix for this has been added to the trunk of the ExhibitBuiler in our subversion code repository and will be included in the next release of EB.

Thanks, Dave. Could you share that code patch here, like you did with the string function replacement code?

I applied the current trunk from the Subversion repository and it did not fix the bug (on either existing or new exhibits).

okay, I went into the tagged versions and found this solution for the HTML bug in the effected layouts (image-list-left/right, image-list-left/right-thumbs):

replace the following code in the layout.php files, inside the "exhibit-text" div:

<?php echo html_escape($text); ?>

<?php echo $text; ?>

Don't try to apply the entire trunk as it has some errors but this little fix does seem to work.