Forums » Errors with every change to items

RSS feed for this topic


  1. We are working on a digital thesis archive site which requires the ability to upload PDFs, images, and uses the map function. We've been having trouble with every aspect of the item addition process - each time a new item is added, each subsequent saving of that information prompts an error from Omeka. With just adding the Dublin Core info, I am able to go back in my browser after receiving the error message saying that there was a problem saving, but the information that it said it could not save will all be there. The real problem is when we try and upload (or delete) files attached to the created items. Uploading files will give us the same error message, though it will sometimes actually upload the file. But, when we try to delete a file, the same error occurs, but the file will not delete. Similarly, with the map plug-in, saving will result in an error, but when I go back in my browser, the map has not been saved. We thought that the errors were a result of certain permissions not being granted in our FTP file, but those have all been changed and we are still receiving the same errors.

    When trying to delete a file, the error looks like this:
    exception 'Omeka_Storage_Exception' with message 'Unable to delete file.' in /mnt/isilon/hosted_sites/home/hadthesis/web/application/libraries/Omeka/Storage/Adapter/Filesystem.php:153
    Stack trace:
    #0 [internal function]: Omeka_Storage_Adapter_Filesystem->delete('files/6328d2c8a...')
    #1 /mnt/isilon/hosted_sites/home/hadthesis/web/application/libraries/Omeka/Storage.php(66): call_user_func_array(Array, Array)
    #2 /mnt/isilon/hosted_sites/home/hadthesis/web/application/models/File.php(232): Omeka_Storage->__call('delete', Array)
    #3 /mnt/isilon/hosted_sites/home/hadthesis/web/application/models/File.php(232): Omeka_Storage->delete('files/6328d2c8a...')
    #4 /mnt/isilon/hosted_sites/home/hadthesis/web/application/models/File.php(238): File->unlinkFile()
    #5 /mnt/isilon/hosted_sites/home/hadthesis/web/application/libraries/Omeka/Record.php(622): File->_delete()
    #6 /mnt/isilon/hosted_sites/home/hadthesis/web/application/models/Item.php(253): Omeka_Record->delete()
    #7 /mnt/isilon/hosted_sites/home/hadthesis/web/application/models/Item.php(233): Item->_deleteFiles()
    #8 /mnt/isilon/hosted_sites/home/hadthesis/web/application/libraries/Omeka/Record.php(622): Item->_delete()
    #9 /mnt/isilon/hosted_sites/home/hadthesis/web/application/libraries/Omeka/Controller/Action.php(517): Omeka_Record->delete()
    #10 /mnt/isilon/hosted_sites/home/hadthesis/web/application/controllers/ItemsController.php(149): Omeka_Controller_Action->deleteAction()
    #11 /mnt/isilon/hosted_sites/home/hadthesis/web/application/libraries/Zend/Controller/Action.php(513): ItemsController->deleteAction()
    #12 /mnt/isilon/hosted_sites/home/hadthesis/web/application/libraries/Zend/Controller/Dispatcher/Standard.php(295): Zend_Controller_Action->dispatch('deleteAction')
    #13 /mnt/isilon/hosted_sites/home/hadthesis/web/application/libraries/Zend/Controller/Front.php(954): Zend_Controller_Dispatcher_Standard->dispatch(Object(Zend_Controller_Request_Http), Object(Zend_Controller_Response_Http))
    #14 /mnt/isilon/hosted_sites/home/hadthesis/web/application/libraries/Zend/Application/Bootstrap/Bootstrap.php(97): Zend_Controller_Front->dispatch()
    #15 /mnt/isilon/hosted_sites/home/hadthesis/web/application/libraries/Zend/Application.php(366): Zend_Application_Bootstrap_Bootstrap->run()
    #16 /mnt/isilon/hosted_sites/home/hadthesis/web/application/libraries/Omeka/Core.php(166): Zend_Application->run()
    #17 /mnt/isilon/hosted_sites/home/hadthesis/web/admin/index.php(45): Omeka_Core->run()
    #18 {main}

    We have tried everything we can think of and are stumped. If anyone can help, we would greatly appreciate it. Thank you!

  2. The "unable to delete file" error doesn't occur in the most recent version of Omeka, 1.4.2. Upgrading will get rid of that error message.

    The root of your problem is probably the error you're getting when you try to save an item, though. What is that error message.

The forums are closed to new posts. To post new topics and read the latest discussions, please see the new forums.