Dropbox permissions error message

I am getting this error message when trying to upload one or more files from the dropbox in /var/data/omeka/plugins/Dropbox/files

I see all the files (in this case just one) from the Dropbox plugin interface but when I try to run the add I get the following message:

"Please make the following dropbox file readable and writeable: /var/data/omeka/plugins/Dropbox/files/P5064119.jpg"

I have gone so far as to give 777 to the directory, but get the same message.

I see in the documentation here:

That I should: "Make 'files' folder located in the Dropbox plugin writable."


"1. After following the instructions and properly making the /files/ folder writeable, FTP files to that folder."

I can't, however, find the specific permissions the system wants. In other words what is "properly writeable" defined as?



This works, but seems a bit too open. ;)

sudo chmod -R 777 /var/data/omeka/plugins/Dropbox/files/

Try chmod 775 files/*
for the /Dropbox plugin.

The asterisk should make all of the files writable in the Dropbox.


Hi Sheila, So I think the issue is that I am uploading as one user and opeka is running a another user and it is the opeka user that should have the permissions. I guess it isn't that big of a deal, though, since if I am batching uploads I can just adjust permissions each time. It is strange, though.

And why I have "opeka" stuck in my head instead of "omeka" I don't know. :)

ssemone: The Dropbox/files directory should be recursively writable by the server (777, not 775). You can use this command to do that, assuming you change directory into the Dropbox directory:

chmod -r 777 files

This will ensure that you don't have to change permissions each time you upload files to the 'files' directory.

I just installed Dropbox have been having two problems: Setting the permissions and allowing the filetypes. When I upload a new file and try to import it, I get the message that I have to set permissions. I do this, using chmod -R 777 files (it didn't like the lowercase r but accepted the R). This works, but only until I upload a new file, which seems to reset it, because I get the error again.
Setting the permissions gets me past the first hurdle, but then it balks at file type, for jpg and tif. I did the addition of jpg and png to the allowed files list as per the instructions, but it didn't fix it. If I turn the filtering off it works, but I suppose it is a bad idea to leave it that way. Pdf files work OK, have not tried others so far.

Hi Matthew,

In the security settings, you need to make sure that both the file extensions and the file mime-types are specified correctly. Can you post the specific error message you are getting when you try to upload jpg files?

Hi all -

I'm having a similar problem. I tried using the chmod -r 777 command folks have mentioned, but terminal is telling me that "no such file or directory exists". I'm pretty sure I have the right file path, so I'm not sure what's up: `var/www/omeka/plugins/Dropbox/files'

Any sugestions?


Where did you get the plugin from?

Did you just download a zip from the Omeka addons directory, or did you get it directly from Github or somewhere else?

I got it from the Omeka directory. And actually, I managed to get it working by going into the file itself and manually changing the permissions. That seems to work just fine!

Glad to hear it.

The problem might have been as simple as a missing forward slash in that path you posted.

Going to the directory from where you already were works just fine too.