Dropbox errors


I used the Dropbox plug-in to upload 495 JPEGS and now I need to associate them with 495 corresponding records.

When I go into the File tab of a record and attempt to associate the file that way, I get the following error:

Method named moveFileToArchive does not exist!

When I go into the Dropbox primary tab, and choose the item, and click 'Upload', I get this:

An error has occurred in Omeka. To track the contents of this error, please enable error logging.

I made the Dropbox /file/ directory writable, though the items within do not appear to be writable (644). Making the items writable does not seem to have an impact.

I am running Omeka 1.0 Alpha.

Thanks for your help.


Hi, the Dropbox plugin has not been released yet to work with 1.0, so you may experience crazy bugs or fatal errors like the above. As soon as it is released, we will post a notice to the blog.

Sorry for any confusion when downloading it; we're still working out the kinks on the site layout to indicate compatibility between specific plugins and Omeka releases.

For now, the easiest way to determine whether or not a plugin you download is compatible with the version you're using, look at the name of the zip file. There are 2 version numbers at the end, separated by a hyphen, like so: omeka-contribution-0.10-0.1.zip. The first number indicates the version of Omeka for which the plugin is released, and the second indicates the version of the plugin itself. Hope that helps!

We're having this error too -- we'd much appreciate an update to the Dropbox plugin!

Dropbox has recently been released to work with 1.0, so try it and let us know if you still have any problems.

Download here: http://omeka.org/files/plugins/dropbox-plugin-1.0-0.3.zip


I'm running Omeka, version 1.0beta and dropbox-plugin-1.0-0.3.zip. The only error I get is "ERR (3): Method named moveFileToArchive does not exist!"

CsvImport-1.0-1.0alpha.zip also just hangs on "Import In Progress".

Is there anything I can do?

Thanks in advance.

I'm getting the same error with the 1.0 release.

Method named moveFileToArchive does not exist!

The yellow box it pops up in is very pretty, though ;)

I'm getting a different error when I upload a JPEG:
ERR (3): The file 'bennettphoto.jpg' could not be ingested because it has a disallowed MIME type (regular file).

Thanks for any help with this.

For folks getting the 'Method named moveFileToArchive does not exist!': Sounds like you're using, or were using, an older version of the Dropbox, which used the moveFilesToArchive method. That was a method in the File model in Omeka 0.10 but was deprecated in version 1.0.

If you're upgrading from a previous version of Dropbox, deactivate the plugin, then reactivate it and see if you still get the same error.

If you're using Omeka 1.0, and Dropbox 1.0-0.3, and have deactivated/reactivated the plugin after upgrading your Omeka installation, there should be no mention whatsoever of the moveFileToArchive method anywhere in the system.

Dropbox 1.0-0.3 will have its version number in the plugin.ini file. If it doesn't include the version number, you're more than likely using an older version of the plugin, but you can download the newest version here:


If none of this helps, let us know and we'll figure something else out!

For a simple run-down for upgrading plugins, there's this page in our Documentation:


delevinson: 'regular file' is not only the white-list of allowed MIME types, and to be honest I'm not sure why you're getting 'regular file' for a JPEG. This is related to the kinds of files allowed for upload by Omeka, which you can configure; Its not (or shouldn't be) unique to the Dropbox plugin.

You can either add 'regular file' to the allowed MIME types in Admin > Settings > General Settings, in the field 'Allowed File Types', or you can just check the 'Disable the Default Validation for File Uploads' to forgo the file upload validations.

There is a similar thread in our Forums about MIME types here:


At the moment, you should be able to just edit the HTML for that form element in order to make it display the languages you want. That file is located at admin/themes/default/items/form.php in your Omeka installation. Keep in mind that this will be changing in the upcoming version of the software, but for now that is the easiest way.

There is a similar thread in our Forums about MIME types here:


In that thread, an interesting post was recently put up, that could possibly solve this issue with security settings, read here:

You may have to check with your hosting service or webmaster, because there might be something else happening.

One other strategy is to change the security settings--mentioned above--and be sure to uncheck the box next to "Disable File Upload Validation."